[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#12565: closed (24.2.50; bootstrap failure: semanti

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#12565: closed (24.2.50; bootstrap failure: semantic-displayor-tooltip-mode)
Date: Wed, 03 Oct 2012 10:41:02 +0000

Your message dated Wed, 03 Oct 2012 12:39:27 +0200
with message-id <address@hidden>
and subject line Re: bug#12565: 24.2.50; bootstrap failure: 
has caused the debbugs.gnu.org bug report #12565,
regarding 24.2.50; bootstrap failure: semantic-displayor-tooltip-mode
to be marked as done.

(If you believe you have received this mail in error, please contact

12565: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=12565
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 24.2.50; bootstrap failure: semantic-displayor-tooltip-mode Date: Wed, 03 Oct 2012 00:40:07 +0200 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2.50 (gnu/linux)
I just updated to trunk revision 110349, and make bootstrap failed:

Compiling /data/steve/bzr/emacs/quickfixes/lisp/cedet/semantic/complete.el

In toplevel form:
Symbol's value as variable is void: semantic-displayor-tooltip-mode
make[3]: *** [cedet/semantic/complete.elc] Error 1
make[3]: Leaving directory `/data/steve/lib/emacs/gtk/lisp'
make[2]: *** [compile-main] Error 2
make[2]: Leaving directory `/data/steve/lib/emacs/gtk/lisp'
make[1]: *** [lisp] Error 2
make[1]: Leaving directory `/data/steve/lib/emacs/gtk'
make: *** [bootstrap] Error 2

--- End Message ---
--- Begin Message --- Subject: Re: bug#12565: 24.2.50; bootstrap failure: semantic-displayor-tooltip-mode Date: Wed, 03 Oct 2012 12:39:27 +0200 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2.50 (gnu/linux)
On Wed, 03 Oct 2012 09:03:58 +0200 David Engster <address@hidden> wrote:

> Glenn Morris writes:
>> Presumably bzr status show nothing odd?

Actually, it listed lots of *.moved files from an earlier bzr bisect.
Should they have been there?  Yet they didn't prevent previous
successful builds...

>> Phase of the moon?
>> make maintainer-clean and try again?
>> semantic-displayor-tooltip-mode is defined at semantic/complete.el:1550
>> so it's hard to see how it can be void at line 1596.
> I must admit I've seen the same problem, 

Interesting, and somehow reassuring.

>                                          but it "somehow went away" and
> I was unable to reproduce it afterwards. Maybe it was a maintainer-clean
> that fixed it.

I deleted the branch and branched again from trunk, and this time
bootstrapping worked.  Maybe it was just a phase of the moon.  Anyway,
there doesn't seem to be anything to pursue now, so I'm closing this

Steve Berman

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]