[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#18770: closed (24.3; Non-whitespace buffer backgro

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#18770: closed (24.3; Non-whitespace buffer background not rendered at all)
Date: Sat, 25 Oct 2014 07:23:02 +0000

Your message dated Sat, 25 Oct 2014 09:21:49 +0200
with message-id <address@hidden>
and subject line Re: bug#18770: Solved.
has caused the debbugs.gnu.org bug report #18770,
regarding 24.3; Non-whitespace buffer background not rendered at all
to be marked as done.

(If you believe you have received this mail in error, please contact

18770: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18770
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 24.3; Non-whitespace buffer background not rendered at all Date: Sun, 19 Oct 2014 16:35:36 +0300
When using Emacs on desktop, the background area which does not contain
characters or whitespaces is not rendered at all, instead that space
gets garbled when scrolling buffer up or down or when alt-tabbing
between windows, making the editor essentially unusable.

I have no idea what could possibly trigger this bug. I'm using Kubuntu
14.10 and this has been and issue for at least a couple of
dist-upgrades. When I start Emacs and load a file, everything still looks
normal but when I start working, the screen is getting garbled. I have
tried both stable and latest git versions without luck.

Here is a screenshot to demonstrate the bug:


However, running Emacs in terminal works fine.

In GNU Emacs 24.3.1 (x86_64-pc-linux-gnu, GTK+ Version 3.10.9)
 of 2014-06-06 on brownie, modified by Debian
Windowing system distributor `The X.Org Foundation', version 11.0.11600000
System Description: Ubuntu 14.10

Configured using:
 `configure '--build' 'x86_64-linux-gnu' '--build' 'x86_64-linux-gnu'
 '--prefix=/usr' '--sharedstatedir=/var/lib' '--libexecdir=/usr/lib'
 '--localstatedir=/var/lib' '--infodir=/usr/share/info'
 '--mandir=/usr/share/man' '--with-pop=yes'
 '--with-crt-dir=/usr/lib/x86_64-linux-gnu' '--with-x=yes'
 '--with-x-toolkit=gtk3' '--with-toolkit-scroll-bars'
 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fstack-protector
 --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wall'
 'LDFLAGS=-Wl,-Bsymbolic-functions -Wl,-z,relro'

Important settings:
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8-unix
  default enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  tooltip-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:
M-x r e p o <tab> r t <tab> <return>

Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.
Making completion list...

Load-path shadows:
None found.

(shadow sort gnus-util mail-extr emacsbug message format-spec rfc822 mml
mml-sec mm-decode mm-bodies mm-encode mail-parse rfc2231 mailabbrev
gmm-utils mailheader sendmail rfc2047 rfc2045 ietf-drums mm-util
mail-prsvr mail-utils help-mode easymenu time-date tooltip ediff-hook
vc-hooks lisp-float-type mwheel x-win x-dnd tool-bar dnd fontset image
regexp-opt fringe tabulated-list newcomment lisp-mode register page
menu-bar rfn-eshadow timer select scroll-bar mouse jit-lock font-lock
syntax facemenu font-core frame cham georgian utf-8-lang misc-lang
vietnamese tibetan thai tai-viet lao korean japanese hebrew greek
romanian slovak czech european ethiopic indian cyrillic chinese
case-table epa-hook jka-cmpr-hook help simple abbrev minibuffer loaddefs
button faces cus-face macroexp files text-properties overlay sha1 md5
base64 format env code-pages mule custom widget hashtable-print-readable
backquote make-network-process dbusbind dynamic-setting
system-font-setting font-render-setting move-toolbar gtk x-toolkit x
multi-tty emacs)

--- End Message ---
--- Begin Message --- Subject: Re: bug#18770: Solved. Date: Sat, 25 Oct 2014 09:21:49 +0200

> 23 okt 2014 kl. 12:58 skrev Jani Alanko <address@hidden>:
> Apparently the Adwaita theme had something to do with this, simply changing 
> the theme to anything else solved the problem.

Good to know.  Closing.

        Jan D.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]