[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#21111: closed (GNU tar warns about zeroed timestam

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#21111: closed (GNU tar warns about zeroed timestamps in binary tarball)
Date: Wed, 22 Jul 2015 21:00:03 +0000

Your message dated Wed, 22 Jul 2015 22:59:05 +0200
with message-id <address@hidden>
and subject line Re: bug#21111: possibly bogus in binary tarball
has caused the debbugs.gnu.org bug report #21111,
regarding GNU tar warns about zeroed timestamps in binary tarball
to be marked as done.

(If you believe you have received this mail in error, please contact

21111: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=21111
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: possibly bogus in binary tarball Date: Wed, 22 Jul 2015 12:55:13 +0100 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.4 (gnu/linux)
The timestamps in the guix-binary-0.8.3.x86_64-linux.tar.xz tarball are
all at the epoch, so unpacking it spews messages like

  tar: ./var/guix: implausibly old time stamp 1970-01-01 01:00:00

I guess that's not intentional, but if it is, it's probably worth a note
in the installation instructions.

--- End Message ---
--- Begin Message --- Subject: Re: bug#21111: possibly bogus in binary tarball Date: Wed, 22 Jul 2015 22:59:05 +0200 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)
Dave Love <address@hidden> skribis:

> Ludovic Courtès <address@hidden> writes:
>> Interestingly, I do not get this message, both with ‘tar xf’ and
>> ‘tar xvf’ with GNU tar 1.28.
>> I tried with different timezones, and I can’t trigger it.
>> Dave: What version of GNU tar do you use, and in what timezone?
>> TIA,
>> Ludo’.
> It was on RHEL6 in the UK zone
>   $ grep -I zone /etc/sysconfig/clock
>   ZONE="Europe/London"
> with:
>   $ rpm -q tar
>   tar-1.23-11.el6.x86_64
> There aren't any obviously-relevant patches in the tar package changelog.

According to the 1.28 manual (info "(tar) warnings"), this specific
warning can be explicitly enabled with --warning=timestamp.

However, I tried variations of the following command with no luck:

  TZ=Europe/London tar --warning=timestamp --extract -f \

So maybe the fact that 1.28 doesn’t emit the warning is a bug.

> I think it would be worth a note on the timestamps anyway to avoid
> confusion and make sure they're maintained, if they should be.  (Excuse
> me if that's done somewhere, but I just went to the current installation
> instructions.)

I’ve added this to the installation instructions in commit aafa0df:

   Some versions of GNU tar raise a warning about “implausibly old
   time stamps”.  This is because all the files in the archive have
   their modification time set to zero (which means January 1st,
   1970.)  This is done on purpose to make sure the archive content is
   independent of its creation time, thus making it reproducible.



--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]