[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#21261: closed (24.5; libxml2 not found on windows

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#21261: closed (24.5; libxml2 not found on windows even when the .dll file is in the bin folder)
Date: Sun, 16 Aug 2015 16:15:02 +0000

Your message dated Sun, 16 Aug 2015 19:14:44 +0300
with message-id <address@hidden>
and subject line Re: bug#21261: 24.5; libxml2 not found on windows even when 
the .dll file is in the bin folder
has caused the debbugs.gnu.org bug report #21261,
regarding 24.5; libxml2 not found on windows even when the .dll file is in the 
bin folder
to be marked as done.

(If you believe you have received this mail in error, please contact

21261: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=21261
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 24.5; libxml2 not found on windows even when the .dll file is in the bin folder Date: Fri, 14 Aug 2015 18:46:05 -0500
On Windows 8.1 when trying to use the eww browser (for example, by
hitting M-x eww RET google.com RET), I get libxml2 not found. I have the
libxml2 .dll (downloaded from ezwinport) in my emacs/bin folder. I have
also tried copying the entire libxml2 folder inside the emacs or
emacs/bin folder, but none of them solved the issue. I was able to
enlist the help of Clement, the maintainer for the company-coq package
(which was the original point where I discovered the bug), who was
unable to replicate the issue. Similarly, googling turns out some old
threads about the same issue, which was solved by just placing the .dll
in the bin folder. But as I said this did not work for me.

In GNU Emacs 24.5.1 (i686-pc-mingw32)
 of 2015-04-11 on LEG570
Windowing system distributor `Microsoft Corp.', version 6.3.9600
Configured using:
 `configure --prefix=/c/usr --host=i686-pc-mingw32'

Important settings:
  value of $LANG: ENU
  locale-coding-system: cp1252

Major mode: Fundamental

Minor modes in effect:
  tooltip-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  buffer-read-only: t
  line-number-mode: t
  transient-mark-mode: t

Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.

Load-path shadows:
None found.

(shadow sort gnus-util mail-extr emacsbug message format-spec rfc822 mml
easymenu mml-sec mm-decode mm-bodies mm-encode mail-parse rfc2231
mailabbrev gmm-utils mailheader sendmail rfc2047 rfc2045 ietf-drums
mm-util help-fns mail-prsvr mail-utils time-date tooltip electric
uniquify ediff-hook vc-hooks lisp-float-type mwheel dos-w32 ls-lisp
w32-common-fns disp-table w32-win w32-vars tool-bar dnd fontset image
regexp-opt fringe tabulated-list newcomment lisp-mode prog-mode register
page menu-bar rfn-eshadow timer select scroll-bar mouse jit-lock
font-lock syntax facemenu font-core frame cham georgian utf-8-lang
misc-lang vietnamese tibetan thai tai-viet lao korean japanese hebrew
greek romanian slovak czech european ethiopic indian cyrillic chinese
case-table epa-hook jka-cmpr-hook help simple abbrev minibuffer nadvice
loaddefs button faces cus-face macroexp files text-properties overlay
sha1 md5 base64 format env code-pages mule custom widget
hashtable-print-readable backquote make-network-process w32notify w32
multi-tty emacs)

Memory information:
((conses 8 74544 6600)
 (symbols 32 17432 0)
 (miscs 32 73 158)
 (strings 16 10697 4045)
 (string-bytes 1 280388)
 (vectors 8 9569)
 (vector-slots 4 384463 4244)
 (floats 8 58 236)
 (intervals 28 245 36)
 (buffers 508 13))

--- End Message ---
--- Begin Message --- Subject: Re: bug#21261: 24.5; libxml2 not found on windows even when the .dll file is in the bin folder Date: Sun, 16 Aug 2015 19:14:44 +0300
> Date: Sun, 16 Aug 2015 11:07:03 -0500
> From: Greg Yang <address@hidden>
> Cc: address@hidden
> OK it turns out I did have libxml2.dll, not libxml2-2.dll. I thought I
> downloaded the package from ezwinports, but I actually didn't (and I don't 
> know
> where I downloaded the binaries for libxml2.dll from). Downloading from
> ezwinports fixed the issue.

OK, I'm closing the bug.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]