emacs-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#16791: closed (w3m fails to do any SSL certificate


From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#16791: closed (w3m fails to do any SSL certificate checking)
Date: Wed, 10 Feb 2016 21:17:02 +0000

Your message dated Wed, 10 Feb 2016 16:16:41 -0500
with message-id <address@hidden>
and subject line Re: bug#16791: w3m fails to do any SSL certificate checking
has caused the debbugs.gnu.org bug report #16791,
regarding w3m fails to do any SSL certificate checking
to be marked as done.

(If you believe you have received this mail in error, please contact
address@hidden)


-- 
16791: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16791
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: w3m fails to do any SSL certificate checking Date: Tue, 18 Feb 2014 03:58:21 -0500
In Guix, neither w3m nor emacs-w3m warn me when I visit an https URL
that uses a server certificate that is both self-signed and expired.
To make matters worse, if I ask for page information (with the '=' key),
it tells me that the certificate is valid.

On Debian, both w3m and emacs-w3m inform me when an SSL certificate is
invalid in some way, e.g. if it's expired or not signed by a certificate
authority in my trust store.

      Mark



--- End Message ---
--- Begin Message --- Subject: Re: bug#16791: w3m fails to do any SSL certificate checking Date: Wed, 10 Feb 2016 16:16:41 -0500 User-agent: Mutt/1.5.24 (2015-08-30)
On Thu, Jan 07, 2016 at 11:55:12PM -0500, Leo Famulari wrote:
> On Tue, Jan 05, 2016 at 11:32:14AM -0500, Leo Famulari wrote:
> > On Tue, Jan 05, 2016 at 12:35:57AM +0100, Ludovic Court├Ęs wrote:

[...]

> > > What about using the latest upstream tarball, along with the patch
> > > above and probably the one that disables SSLv{2,3}?
> > 
> > I'll try that.
> 
> Mark, can you check if commit 62339e2d49 fixes this bug for you?

I believe this bug is fixed. Please re-open if that is not the case.


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]