[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#22896: closed (25.0.92; Pasting from system clipbo

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#22896: closed (25.0.92; Pasting from system clipboard into tty emacs I-search minibuffer ends up in buffer instead)
Date: Sun, 05 Jun 2016 21:18:02 +0000

Your message dated Mon, 06 Jun 2016 00:14:19 +0300
with message-id <address@hidden>
and subject line Re: bug#22896: 25.0.92; Pasting from system clipboard into tty 
emacs I-search minibuffer ends up in buffer instead
has caused the debbugs.gnu.org bug report #22896,
regarding 25.0.92; Pasting from system clipboard into tty emacs I-search 
minibuffer ends up in buffer instead
to be marked as done.

(If you believe you have received this mail in error, please contact

22896: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=22896
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 25.0.92; Pasting from system clipboard into tty emacs I-search minibuffer ends up in buffer instead Date: Wed, 2 Mar 2016 22:31:48 -0800
I'm running Emacs on OS X 10.11.3 in tty mode (-nw) in either
Terminal.app or iTerm2. Often times I would copy some text from, say, a
web page, and search it in the current buffer with isearch-forward (C-s)
or isearch-backward (C-r) by pasting the copied text into the isearch
minibuffer with Cmd+V. This worked up till 24.5, but in (I
haven't tested in other prereleases), Cmd+V won't paste the system
clipboard text into the minibuffer, but instead, straight into the
buffer at the point. Exact steps to reproduce:

1. emacs -Q -nw (which lands us in the *scratch* buffer);
2. Copy something onto system clipboard;
3. C-s to bring up the I-search: minibuffer;
4. Cmd+V to paste from system clipboard;

Expected behavior (24.5 and before):

System clipboard text lands in the I-search minibuffer.

Actual behavior:

System clipboard text lands in the *scratch* buffer, while the I-search
minibuffer remains empty.

Unfortunately his is rather disrupting to some of my workflows. Thanks
for your time.


In GNU Emacs (x86_64-apple-darwin15.3.0, NS appkit-1404.34 Version 
10.11.3 (Build 15D21))
of 2016-03-02 built on mid-2015-rMBP-15.local
Configured using:
'configure --prefix=/usr/local/Cellar/emacs/25.0.92
--infodir=/usr/local/Cellar/emacs/25.0.92/share/info/emacs --with-xml2
--with-dbus --with-gnutls --with-rsvg --with-imagemagick --with-ns

Configured features:

Important settings:
  value of $LC_ALL: en_US.UTF-8
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8-unix

Major mode: Lisp Interaction

Minor modes in effect:
  diff-auto-refine-mode: t
  magit-auto-revert-mode: t
  global-git-commit-mode: t
  async-bytecomp-package-mode: t
  shell-dirtrack-mode: t
  auto-complete-mode: t
  auto-insert-mode: t
  ido-everywhere: t
  override-global-mode: t
  tooltip-mode: t
  global-eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  column-number-mode: t
  line-number-mode: t
  transient-mark-mode: t
  hs-minor-mode: t

Recent messages:
When done with a buffer, type C-x C-k
Mark saved where search started
Quit [3 times]
Mark set
Mark set
C-s runs the command isearch-forward

Load-path shadows:
/Users/zmwang/.emacs.d/lisp/misc hides 

(shadow sort mail-extr emacsbug sendmail thingatpt hi-lock
character-fold misearch multi-isearch dired-aux linum term/xterm xterm
web-beautify magit-blame magit-stash magit-bisect magit-remote
magit-commit magit-sequence magit magit-apply magit-wip magit-log
magit-diff smerge-mode diff-mode magit-core magit-autorevert autorevert
filenotify magit-process magit-popup magit-mode magit-git crm
magit-section magit-utils git-commit log-edit message idna dired rfc822
mml mml-sec epg mm-decode mm-bodies mm-encode mail-parse rfc2231 rfc2047
rfc2045 ietf-drums mailabbrev mail-utils gmm-utils mailheader pcvs-util
add-log with-editor async-bytecomp async tramp-sh tramp tramp-compat
auth-source cl-seq eieio eieio-core gnus-util mm-util help-fns
mail-prsvr password-cache tramp-loaddefs trampver shell pcomplete
format-spec pasteboard server hideshow flycheck find-func rx subr-x dash
advice flymake compile comint ansi-color ring auto-complete popup
autoinsert misc ido seq byte-opt time-date cc-mode cc-fonts cc-guess
cc-menus cc-cmds cc-styles cc-align cc-engine cc-vars cc-defs edmacro
kmacro color use-package cl-macs cl gv diminish bytecomp byte-compile
cl-extra help-mode cconv bind-key easy-mmode cl-loaddefs pcase cl-lib
finder-inf tex-site go-mode-autoloads info package easymenu epg-config
mule-util tooltip eldoc electric uniquify ediff-hook vc-hooks
lisp-float-type mwheel ns-win ucs-normalize term/common-win tool-bar dnd
fontset image regexp-opt fringe tabulated-list newcomment elisp-mode
lisp-mode prog-mode register page menu-bar rfn-eshadow timer select
scroll-bar mouse jit-lock font-lock syntax facemenu font-core frame
cl-generic cham georgian utf-8-lang misc-lang vietnamese tibetan thai
tai-viet lao korean japanese eucjp-ms cp51932 hebrew greek romanian
slovak czech european ethiopic indian cyrillic chinese charscript
case-table epa-hook jka-cmpr-hook help simple abbrev minibuffer
cl-preloaded nadvice loaddefs button faces cus-face macroexp files
text-properties overlay sha1 md5 base64 format env code-pages mule
custom widget hashtable-print-readable backquote dbusbind kqueue cocoa
ns multi-tty make-network-process emacs)

Memory information:
((conses 16 370292 21777)
(symbols 48 34892 0)
(miscs 40 102 545)
(strings 32 78032 29848)
(string-bytes 1 2277356)
(vectors 16 51755)
(vector-slots 8 889370 17205)
(floats 8 469 685)
(intervals 56 575 0)
(buffers 976 14))

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

--- End Message ---
--- Begin Message --- Subject: Re: bug#22896: 25.0.92; Pasting from system clipboard into tty emacs I-search minibuffer ends up in buffer instead Date: Mon, 06 Jun 2016 00:14:19 +0300 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (x86_64-pc-linux-gnu)
>> Could you please confirm if this was fixed two weeks ago in
>> http://debbugs.gnu.org/23519
> Yes, I just tried latest master (abfe07a) which includes the fix in
> 869092c, and the bug is fixed. Since the fix already landed in the
> emacs-25 branch, I think we can close this.

Thanks for confirming.  I'm closing the bug.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]