[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#24060: closed (Test failure: tests/publish.scm)

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#24060: closed (Test failure: tests/publish.scm)
Date: Wed, 27 Jul 2016 10:50:02 +0000

Your message dated Wed, 27 Jul 2016 12:49:25 +0200
with message-id <address@hidden>
and subject line Re: bug#24060: Test failure: tests/publish.scm
has caused the debbugs.gnu.org bug report #24060,
regarding Test failure: tests/publish.scm
to be marked as done.

(If you believe you have received this mail in error, please contact

24060: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=24060
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: Test failure: tests/publish.scm Date: Sun, 24 Jul 2016 02:31:53 -0700

I've noticed that tests/publish.scm fails when run with the other tests
in parallel (see attached test-suite.log file).  Specifically, it fails
when I run "make -j check".  It passes when I run "make check".  It
passes when I run "make -j check TESTS=tests/publish.scm".  It also
passes when I run "make check TESTS=tests/publish.scm".  Here's the
failure message:

--8<---------------cut here---------------start------------->8---
test-name: /nar/gzip/*
location: /home/marusich/guix/tests/publish.scm:163
+ (test-equal
+   "/nar/gzip/*"
+   "bar"
+   (call-with-temporary-output-file
+     (lambda (temp port)
+       (let ((nar (http-get-port
+                    (publish-uri
+                      (string-append "/nar/gzip/" (basename %item))))))
+         (call-with-gzip-input-port
+           nar
+           (cut restore-file <> temp)))
+       (call-with-input-file temp read-string))))
GET /nar/gzip/z8qsg9bmmjzgfi0bbgls1wxd0wmhhm2i-item
expected-value: bar
actual-value: #f
+ (srfi-34
+   #<condition &nar-error [file: "/tmp/guix-file.7fzEA2" port: #<closed: 
r6rs-custom-binary-input-port 0>] 27616f0>)
result: FAIL
--8<---------------cut here---------------end--------------->8---

I'm using GuixSD with Guix v0.10.0.  I observed this failure using
commit 8d63dddac11882ef85283bda259e0142b65ae28f.  I built guix with
dependencies provided via "guix environment guix"; however, since there
are two versions of guix defined gnu/packages/package-management.scm,
I'm not sure which one is being used to determine dependencies.


Attachment: test-suite.log
Description: Binary data

Attachment: signature.asc
Description: PGP signature

--- End Message ---
--- Begin Message --- Subject: Re: bug#24060: Test failure: tests/publish.scm Date: Wed, 27 Jul 2016 12:49:25 +0200 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

I managed to reproduce it with more ‘make -j’ runs (it would fail
roughly once every 5 runs).

This is fixed by 37402ecb4379d7199dd4b3386488261938edc780 and the
problem is evidenced by 688ec13c459602d475bccd3638a6802dc0a6ce23.

Thank you!


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]