[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#24324: closed (25.1; emacsclient -c --alternate-ed

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#24324: closed (25.1; emacsclient -c --alternate-editor="" no longer works as described in the manual)
Date: Sun, 28 Aug 2016 12:52:01 +0000

Your message dated Sun, 28 Aug 2016 14:50:53 +0200
with message-id <address@hidden>
and subject line Re: bug#24324: #24324: rescinding the report
has caused the debbugs.gnu.org bug report #24324,
regarding 25.1; emacsclient -c --alternate-editor="" no longer works as 
described in the manual
to be marked as done.

(If you believe you have received this mail in error, please contact

24324: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=24324
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 25.1; emacsclient -c --alternate-editor="" no longer works as described in the manual Date: Sat, 27 Aug 2016 20:28:04 -0400
without a server running: 
$ emacsclient -c --alternate-editor=""

emacsclient: can't find socket; have you started the server?
To start the server in Emacs, type "M-x server-start".
emacsclient: error starting emacs daemon
emacsclient: failed to send 4060 bytes to socket: Bad file descriptor
emacsclient: error executing alternate editor ""
Error: Could not start the Emacs daemon

works just fine with the server running. worked before I updated, but I
haven't updated in a long time, so I don't remember what version I was
on when it last stopped working (sorry about this!) that said, it's a
safe bet I was on 23+

In GNU Emacs 25.1.1 (x86_64-redhat-linux-gnu, GTK+ Version 3.20.6)
 of 2016-07-25 built on buildhw-08.phx2.fedoraproject.org
Windowing system distributor 'Fedora Project', version 11.0.11804000
System Description:     Fedora release 24 (Twenty Four)

Configured using:
 'configure --build=x86_64-redhat-linux-gnu
 --host=x86_64-redhat-linux-gnu --program-prefix=
 --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr
 --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc
 --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64
 --libexecdir=/usr/libexec --localstatedir=/var
 --sharedstatedir=/var/lib --mandir=/usr/share/man
 --infodir=/usr/share/info --with-dbus --with-gif --with-jpeg --with-png
 --with-rsvg --with-tiff --with-xft --with-xpm --with-x-toolkit=gtk3
 --with-gpm=no --with-xwidgets build_alias=x86_64-redhat-linux-gnu
 host_alias=x86_64-redhat-linux-gnu 'CFLAGS=-DMAIL_USE_LOCKF -O2 -g
 -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2
 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4
 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1
 -m64 -mtune=generic' LDFLAGS=-Wl,-z,relro

Configured features:

Important settings:
  value of $LANG: en_US.utf8
  value of $XMODIFIERS: @im=none
  locale-coding-system: utf-8-unix

Major mode: Circe Channel

Minor modes in effect:
  cursor-intangible-mode: t
  hl-line-mode: t
  tracking-mode: t
  pyvenv-mode: t
  which-key-mode: t
  evil-visual-mark-mode: t
  evil-leader-mode: t
  global-undo-tree-mode: t
  undo-tree-mode: t
  evil-mode: t
  evil-local-mode: t
  diff-auto-refine-mode: t
  magit-auto-revert-mode: t
  global-git-commit-mode: t
  async-bytecomp-package-mode: t
  shell-dirtrack-mode: t
  ivy-mode: t
  override-global-mode: t
  tooltip-mode: t
  global-eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent messages:
Source file ‘/home/ajarara/.emacs.d/elpa/swiper-20160810.451/swiper.el’ newer 
than byte-compiled file
Quit [2 times]
Entering debugger...
evil-record-macro: Invalid register
Back to top level
evil-line-move: End of buffer [5 times]
Quit [2 times]
Undo branch point!
Buffer kol-smith.org modified; kill anyway? (y or n) y
delete-backward-char: Text is read-only

Load-path shadows:
/home/ajarara/.emacs.d/elpa/helm-20160812.842/helm-multi-match hides 

(tabify org-indent org-element org-table org-rmail org-mhe org-irc
org-info org-gnus org-docview doc-view subr-x jka-compr image-mode
org-bibtex bibtex org-bbdb org-w3m org org-macro org-footnote
org-pcomplete org-list org-faces org-entities org-version ob-emacs-lisp
ob ob-tangle ob-ref ob-lob ob-table ob-exp org-src ob-keys ob-comint
ob-core ob-eval org-compat org-macs org-loaddefs find-func cal-menu
calendar cal-loaddefs term disp-table ehelp debug man swiper
cursor-sensor network-stream nsm starttls mailalias smtpmail vc-git
colir ace-window avy shadow sort mail-extr emacsbug sendmail winner
helm-command helm-elisp helm-eval edebug helm-mode helm-files
image-dired dired-x dired-aux helm-buffers helm-elscreen helm-tags
helm-bookmark helm-adaptive helm-info info bookmark helm-locate
helm-grep helm-regexp helm-external helm-net xml helm-utils helm-types
helm-help helm helm-source eieio-compat helm-multi-match helm-lib
hl-line ledger-mode ledger-check ledger-schedule ledger-xact ledger-texi
ledger-test ledger-sort ledger-report ledger-reconcile ledger-post
ledger-occur ledger-init ledger-fontify ledger-state ledger-navigate
ledger-fonts ledger-exec ledger-context ledger-complete
ledger-commodities esh-var esh-io esh-cmd esh-opt esh-ext esh-proc
esh-groups eshell esh-module esh-mode esh-arg esh-util ledger-regex
sml-mode smie try url url-proxy url-privacy url-expand url-methods
url-history url-cookie url-domsuf url-util mailcap monokai-theme
circe-color-nicks color circe lui-irc-colors irc make-tls-process tls
gnutls lcs lui-format lui tracking shorten rx paren flyspell ispell
circe-compat slime arc-mode archive-mode noutline outline pp hyperspec
browse-url mingus libmpdee cl yasnippet highlight-indentation flymake
company elpy pyvenv elpy-refactor python ido grep compile files-x etags
xref project cus-edit wid-edit which-key evil-visual-mark-mode
evil-leader evil evil-integration undo-tree diff evil-maps evil-commands
evil-jumps evil-command-window evil-types evil-search evil-ex
evil-macros evil-repeat evil-states evil-core evil-common windmove rect
evil-digraphs evil-vars magit-blame magit-stash magit-bisect
magit-remote magit-commit magit-sequence magit magit-apply magit-wip
magit-log magit-diff smerge-mode diff-mode magit-core magit-autorevert
autorevert filenotify magit-process magit-popup magit-mode magit-git crm
magit-section magit-utils git-commit log-edit message idna rfc822 mml
mml-sec epg mailabbrev mail-utils gmm-utils mailheader pcvs-util add-log
with-editor async-bytecomp async tramp-sh tramp tramp-compat
tramp-loaddefs trampver ucs-normalize shell pcomplete comint ansi-color
ring format-spec advice server dash edmacro kmacro ivy delsel ffap
thingatpt dired use-package diminish bind-key easy-mmode parse-time
quelpa url-parse auth-source cl-seq eieio eieio-core cl-macs gnus-util
time-date password-cache url-vars package-build mm-decode mm-bodies
mm-encode mail-parse rfc2231 rfc2047 rfc2045 ietf-drums mm-util help-fns
mail-prsvr json map lisp-mnt finder-inf slime-autoloads package
epg-config seq byte-opt gv bytecomp byte-compile cl-extra help-mode
easymenu cconv cl-loaddefs pcase cl-lib cus-start cus-load mule-util
tooltip eldoc electric uniquify ediff-hook vc-hooks lisp-float-type
mwheel x-win term/common-win x-dnd tool-bar dnd fontset image regexp-opt
fringe tabulated-list newcomment elisp-mode lisp-mode prog-mode register
page menu-bar rfn-eshadow timer select scroll-bar mouse jit-lock
font-lock syntax facemenu font-core frame cl-generic cham georgian
utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao korean
japanese eucjp-ms cp51932 hebrew greek romanian slovak czech european
ethiopic indian cyrillic chinese charscript case-table epa-hook
jka-cmpr-hook help simple abbrev minibuffer cl-preloaded nadvice
loaddefs button faces cus-face macroexp files text-properties overlay
sha1 md5 base64 format env code-pages mule custom widget
hashtable-print-readable backquote dbusbind inotify dynamic-setting
system-font-setting font-render-setting xwidget-internal move-toolbar
gtk x-toolkit x multi-tty make-network-process emacs)

Memory information:
((conses 16 693013 55648)
 (symbols 48 56275 10)
 (miscs 40 348 608)
 (strings 32 151365 25490)
 (string-bytes 1 4390102)
 (vectors 16 89470)
 (vector-slots 8 1660398 19673)
 (floats 8 986 299)
 (intervals 56 7309 1443)
 (buffers 976 31)
 (heap 1024 58592 5277))

--- End Message ---
--- Begin Message --- Subject: Re: bug#24324: #24324: rescinding the report Date: Sun, 28 Aug 2016 14:50:53 +0200 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1.50 (gnu/linux)
Ahmad Jarara <address@hidden> writes:

> I reported too soon: the problem wasn't emacs, fedora packages the latest
> emacs as "emacs-25.1"
> symlinking it to emacs in /usr/bin/emacs solved the issue referenced (that
> is, emacsclient -c --alternate-editor="" not working)

Ok, closing the bug report.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]