[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#22985: closed (using gnune-gtk with ratpoison (gnu

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#22985: closed (using gnune-gtk with ratpoison (gnunet-fs in -gtk nonfunctional) -> needs participation and input)
Date: Sat, 11 Feb 2017 17:26:02 +0000

Your message dated Sat, 11 Feb 2017 17:27:11 +0000
with message-id <address@hidden>
and subject line solved
has caused the debbugs.gnu.org bug report #22985,
regarding using gnune-gtk with ratpoison (gnunet-fs in -gtk nonfunctional) -> 
needs participation and input
to be marked as done.

(If you believe you have received this mail in error, please contact

22985: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=22985
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: using gnune-gtk with ratpoison (gnunet-fs in -gtk nonfunctional) -> needs participation and input Date: Fri, 11 Mar 2016 16:34:15 +0100 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)
This describes a bug with our gnunet-gtk package I am tracking
now in gnu/packages/gnunet.scm and will include it to refer to in
the patch I will send in as soon as I have enough time on this
conference to rebase my (big) patch of gnunet.scm


- Using ratpoison as WM, running gnunet-gtk (svn) gives GSettings
  related errors when opening gnunet-fs (filesharing) tab.
  The error gets more specific when installing gsettings into
  your profile (see irc log, 10.03.2016, grep for "gnunet"
  "gsettings"). I can't be more precise at the moment due to the
  lack of time. I provided some details on IRC on thursday, if I
  have the time this weekend I'll add the exact error messages
  you'll experience, though they are obvious in the terminal

- Reconfiguring the system with xfce in the desktop profile seems
  to provide more than ratpoison, the bug is gone. I have to
  assume that xfce provides gsettings on its own, and that this
  error is specific to minimal window managers without certain
  X11/gtk profiles or otherwise configuration settings which get
  delivered with xfce and the like.

The output (from memory) is visible when you kill/close
gnunet-gtk, look for something related to gnunet-fs ... GIO
.... GSettings .... and later: org.gtk.FileChooser (or something
like that), also in relation to gnunet-fs.

I want people to do the following:
- Install gnunet and gnunet-gtk (both 0.10.1), skip over
  gnunet-setup, and see in gnunet-gtk after running "gnunet-arm
  --start" if the tab for filesharing / publishing is just
  black. In either case of positive or negative confirmation I
  want to know about the used desktop/window manager and
  environment variables to nail down the problem.
- Do the exact same for gnunet-gtk-svn + gnunet-svn.

This bug is published before gnunet-svn, gnunet-gtk-svn and other
changes to gnu/packages/gnunet.scm are send in as patches. I am
currently not in reach of a permanent connection and will provide
rebase and create a patch as soon as I can. Time and too much
input in talks is another factor keeping me from currently
rebasing the patch against master.
Just know that the patch is functional and this bug is considered
something people using windowmanagers equal to ratposion should
help me in solving, as this is caused by an external factor I
have to pin and optimize the gnunet package on or provide a note
for certain environments. In itself, based on a work I
co-authored with Jookia, it is functional.

Sorry if this might read verbose or confusing but I write this
based on something I have written between yesterday, this morning
and in between rushing to the next talk :)

Thanks for your patience,
personal contact: http://krosos.sdf.org
EDN: https://wiki.c3d2.de/Echt_Dezentrales_Netz/en

--- End Message ---
--- Begin Message --- Subject: solved Date: Sat, 11 Feb 2017 17:27:11 +0000
Solved as this seems to be an issue of window managers and not the
application itself.

ng0 -- https://www.inventati.org/patternsinthechaos/

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]