[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#28973: closed ([PATCH 1/1] gnu: Add strongswan.)

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#28973: closed ([PATCH 1/1] gnu: Add strongswan.)
Date: Wed, 31 Jan 2018 22:34:02 +0000

Your message dated Wed, 31 Jan 2018 23:33:54 +0100
with message-id <address@hidden>
and subject line Re: [bug#28973] [PATCH 1/1] gnu: Add strongswan.
has caused the debbugs.gnu.org bug report #28973,
regarding [PATCH 1/1] gnu: Add strongswan.
to be marked as done.

(If you believe you have received this mail in error, please contact

28973: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=28973
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: [PATCH 1/1] gnu: Add strongswan. Date: Tue, 24 Oct 2017 14:58:52 -0400 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)
Their website is not very precise about the licensing.  It just says
GPL2, but all the files I checked were GPL2+, except one which says
"MIT" but is really the text of the Expat license as listen on the FSF

I believe the licensing info is correct now but I didn't do an
exhaustive search of all files.

 gnu/packages/networking.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 633b8ca43..6d639f716 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -78,6 +78,8 @@
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages wm)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages gnuzilla)
   #:use-module (ice-9 match))
 (define-public macchanger
@@ -1494,3 +1496,34 @@ interface and a programmable text output for scripting.")
     ;; Update the license field when upstream responds.
     (license (list license:bsd-2
+(define-public strongswan
+  (package
+    (name "strongswan")
+    (version "5.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://download.strongswan.org/strongswan-"; 
version ".tar.bz2"))
+       (sha256
+        (base32 "04vvha2zgsg1cq05cnn6sf7a4hq9ndnsfxpw1drm5v9l4vcw0kd1"))
+       (patches
+        (search-patches "strongswan-test_process-disable-all.patch"
+    (build-system gnu-build-system)
+    (inputs
+     `(("gmp" ,gmp)
+       ("openssl" ,openssl)
+       ("libgcrypt" ,libgcrypt)
+       ("curl" ,curl)))
+    (synopsis "IKEv1/v2 keying daemon")
+    (description "strongswan is an open source IPSec implementation")
+    (home-page "https://strongswan.org/";)
+    (license
+     ;; Everything seems to be gpl2+ except
+     ;; src/libcharon/plugins/vici/libvici.h which is MIT/expat.  The actual
+     ;; source file "libvici.h" claims it's MIT, but the actual text of the
+     ;; license is identical to expat as listed here:
+     ;; https://directory.fsf.org/wiki/License:Expat
+     (list license:gpl2+
+           license:expat))))

--- End Message ---
--- Begin Message --- Subject: Re: [bug#28973] [PATCH 1/1] gnu: Add strongswan. Date: Wed, 31 Jan 2018 23:33:54 +0100 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)
Adam Van Ymeren <address@hidden> skribis:

> Okay I think I've done all your comments.  I figured out how to get some
> of the tests that were failing to pass so I dropped one of the patches
> and cleaned up the other one.
> I also added non-copyleft license for that one file.
> I spent some time trying to debug the remaining failing tests.  They
> make some assumptions about paths which are not true in the build
> container, I managed to get some to pass when I run manually in a
> container from guix environment -C, but they still fail when $ guix
> build runs, so I've left in the patch to disable them.  They're really
> not essential tests.

I’ve adjusted said file names in test_process.c and in the library,
removed the patch (tests pass!), adjusted the commit log, and pushed as



--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]