[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#31313: closed (26.1; gnutls.c: [0] (Emacs) Receive

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#31313: closed (26.1; gnutls.c: [0] (Emacs) Received alert: Handshake failed)
Date: Sat, 05 May 2018 06:40:01 +0000

Your message dated Sat, 05 May 2018 09:39:27 +0300
with message-id <address@hidden>
and subject line Re: bug#31313: 26.1; gnutls.c: [0] (Emacs) Received alert: 
Handshake failed
has caused the debbugs.gnu.org bug report #31313,
regarding 26.1; gnutls.c: [0] (Emacs) Received alert: Handshake failed
to be marked as done.

(If you believe you have received this mail in error, please contact

31313: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=31313
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 26.1; gnutls.c: [0] (Emacs) Received alert: Handshake failed Date: Sun, 29 Apr 2018 19:59:19 +0000
Put this into /tmp/repro.el

     (setq package-archives
           '(("gnu" . "https://elpa.gnu.org/packages/";)
             ("melpa" . "https://melpa.org/packages/";)
             ("elpy" . "https://jorgenschaefer.github.io/packages/";))

Then run "emacs -Q --load /tmp/repro.el".  You'll see

     gnutls.c: [0] (Emacs) Received alert:  Handshake failed

in the echo area; the *Packages* buffer's mode line will say Package
Menu:Loading for ever, and after typing U you will see "Waiting for
refresh to finish...".  Basically packages are now unusable.

This used to work until perhaps a few days or weeks ago; as far as I
know nothing has changed.

In GNU Emacs 26.1 (build 1, x86_64-pc-linux-gnu)
  of 2018-04-29 built on ip-10-0-0-79
Repository revision: c18ec6afc0ee7fa2ad5831fbd3a51ca4df3c35b7
Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.
Importing package-keyring.gpg...done
Setting ‘package-selected-packages’ temporarily since "emacs -q" would
overwrite customizations
gnutls.c: [0] (Emacs) Received alert:  Handshake failed
Mark set
Mark saved where search started
Waiting for refresh to finish...
current-kill: Kill ring is empty
user-error: Previous command was not a yank

Configured using:
  'configure --without-x'

Configured features:

Important settings:
   value of $LC_ALL: en_US.UTF-8
   value of $LANG: en_US.UTF-8
   locale-coding-system: utf-8-unix

Major mode: Package Menu

Minor modes in effect:
   tooltip-mode: t
   global-eldoc-mode: t
   electric-indent-mode: t
   menu-bar-mode: t
   file-name-shadow-mode: t
   global-font-lock-mode: t
   font-lock-mode: t
   auto-composition-mode: t
   auto-encryption-mode: t
   auto-compression-mode: t
   buffer-read-only: t
   line-number-mode: t
   transient-mark-mode: t

Load-path shadows:
None found.

(shadow sort mail-extr emacsbug message dired dired-loaddefs format-spec
rfc822 mml mml-sec epa derived gnus-util rmail tool-bar rmail-loaddefs
mm-decode mm-bodies mm-encode mailabbrev gmm-utils mailheader sendmail
regexp-opt mail-utils misearch multi-isearch cus-edit cus-start cus-load
wid-edit network-stream starttls url-http tls gnutls mail-parse rfc2231
rfc2047 rfc2045 mm-util ietf-drums mail-prsvr url-gw nsm rmc puny
url-cache url-auth url url-proxy url-privacy url-expand url-methods
url-history url-cookie url-domsuf url-util mailcap epg finder-inf
package easymenu epg-config url-handlers url-parse auth-source cl-seq
eieio eieio-core cl-macs eieio-loaddefs password-cache url-vars seq
byte-opt gv bytecomp byte-compile cconv cl-loaddefs cl-lib term/xterm
xterm time-date elec-pair mule-util tooltip eldoc electric uniquify
ediff-hook vc-hooks lisp-float-type tabulated-list replace newcomment
text-mode elisp-mode lisp-mode prog-mode register page menu-bar
rfn-eshadow isearch timer select mouse jit-lock font-lock syntax
facemenu font-core term/tty-colors frame cl-generic cham georgian
utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao korean
japanese eucjp-ms cp51932 hebrew greek romanian slovak czech european
ethiopic indian cyrillic chinese composite charscript charprop
case-table epa-hook jka-cmpr-hook help simple abbrev obarray minibuffer
cl-preloaded nadvice loaddefs button faces cus-face macroexp files
text-properties overlay sha1 md5 base64 format env code-pages mule
custom widget hashtable-print-readable backquote inotify multi-tty
make-network-process emacs)

Memory information:
((conses 16 888576 36741)
  (symbols 48 35517 1)
  (miscs 40 48 110)
  (strings 32 110311 4947)
  (string-bytes 1 2359526)
  (vectors 16 24138)
  (vector-slots 8 598779 29348)
  (floats 8 58 371)
  (intervals 56 107939 1833)
  (buffers 992 15)
  (heap 1024 53709 8512))

--- End Message ---
--- Begin Message --- Subject: Re: bug#31313: 26.1; gnutls.c: [0] (Emacs) Received alert: Handshake failed Date: Sat, 05 May 2018 09:39:27 +0300
> From: Eric Hanchrow <address@hidden>
> Date: Fri, 04 May 2018 22:49:37 +0000
> Cc: address@hidden
> The latter, as far as I'm concerned.

Thanks, closing.

> On Thu, May 3, 2018 at 10:44 AM Eli Zaretskii <address@hidden> wrote:
> > > From: Eric Hanchrow <address@hidden>
> > > Date: Thu, 03 May 2018 03:24:52 +0000
> > > Cc: address@hidden
> > >
> > > I tried gnutls-cli 3.5.18 and it works -- here's the *Messages* buffer
> > So do we need to investigate this problem further, or can we deduce
> > that the problem is solved by a newer GnuTLS?

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]