[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#32338: closed (26.1; term.el broken on macOS)

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#32338: closed (26.1; term.el broken on macOS)
Date: Thu, 04 Oct 2018 16:16:02 +0000

Your message dated Thu, 04 Oct 2018 19:15:06 +0300
with message-id <address@hidden>
and subject line Re: bug#32338: 26.1; term.el broken on macOS
has caused the debbugs.gnu.org bug report #32338,
regarding 26.1; term.el broken on macOS
to be marked as done.

(If you believe you have received this mail in error, please contact

32338: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=32338
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 26.1; term.el broken on macOS Date: Tue, 31 Jul 2018 15:29:21 -0400
M-x term nor M-x ansi-term both cause Emacs to lock up on macOS
10.13.4. Steps to reproduce with -Q:

1. M-x ansi-term
2. Type in /bin/bash, hit Enter

You'll notice that a prompt does not appear in the resulting window
(*ansi-term* buffer). Hit Enter. Emacs will display "Writing to process:
Input/output error, *ansi-term*" in the minibuffer. If you started Emacs
from the terminal, it will display "Fatal error 4: Illegal
instruction". After this, Emacs becomes unstable and will eventually
stop responding to input. All this worked fine in 25.3 and earlier
(i.e., a shell prompt appears and can be readily used).

In GNU Emacs 26.1 (build 1, x86_64-apple-darwin17.5.0, NS
appkit-1561.40 Version 10.13.4 (Build 17E202))
 of 2018-05-29 built on athena
Windowing system distributor 'Apple', version 10.3.1561
Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.

Configured using:
 'configure --with-ns'

Configured features:

Important settings:
  value of $LC_COLLATE: C
  value of $LC_CTYPE: en_US.UTF-8
  value of $LANG: en_US.UTF-8
  locale-coding-system: utf-8-unix

Major mode: Lisp Interaction

Minor modes in effect:
  tooltip-mode: t
  global-eldoc-mode: t
  eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Load-path shadows:
None found.

(shadow sort mail-extr emacsbug message rmc puny seq byte-opt gv
bytecomp byte-compile cconv cl-loaddefs cl-lib dired dired-loaddefs
format-spec rfc822 mml easymenu mml-sec password-cache epa derived epg
epg-config gnus-util rmail rmail-loaddefs mm-decode mm-bodies mm-encode
mail-parse rfc2231 mailabbrev gmm-utils mailheader sendmail rfc2047
rfc2045 ietf-drums mm-util mail-prsvr mail-utils elec-pair time-date
tooltip eldoc electric uniquify ediff-hook vc-hooks lisp-float-type
mwheel term/ns-win ns-win ucs-normalize mule-util term/common-win
tool-bar dnd fontset image regexp-opt fringe tabulated-list replace
newcomment text-mode elisp-mode lisp-mode prog-mode register page
menu-bar rfn-eshadow isearch timer select scroll-bar mouse jit-lock
font-lock syntax facemenu font-core term/tty-colors frame cl-generic
cham georgian utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao
korean japanese eucjp-ms cp51932 hebrew greek romanian slovak czech
european ethiopic indian cyrillic chinese composite charscript charprop
case-table epa-hook jka-cmpr-hook help simple abbrev obarray minibuffer
cl-preloaded nadvice loaddefs button faces cus-face macroexp files
text-properties overlay sha1 md5 base64 format env code-pages mule
custom widget hashtable-print-readable backquote kqueue cocoa ns
multi-tty make-network-process emacs)

Memory information:
((conses 16 203885 9219)
 (symbols 48 20051 1)
 (miscs 40 43 146)
G (strings 32 28780 1228)
 (string-bytes 1 760308)
 (vectors 16 34997)
 (vector-slots 8 713320 17782)
 (floats 8 48 68)
 (intervals 56 202 0)
 (buffers 992 11))

--- End Message ---
--- Begin Message --- Subject: Re: bug#32338: 26.1; term.el broken on macOS Date: Thu, 04 Oct 2018 19:15:06 +0300
> From: Constantine Vetoshev <address@hidden>
> Date: Wed, 3 Oct 2018 12:21:26 -0700
> Cc: Alan Third <address@hidden>, Noam Postavsky <address@hidden>, 
> address@hidden
> On Wed, Oct 3, 2018 at 7:59 AM Eli Zaretskii <address@hidden> wrote:
> > So please try the patch below with the emacs-26 branch, and see if the
> > problem goes away.
> Yes, that fixed it! Thanks!

Thanks, pushed to the release branch.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]