[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#30929: closed (26.0.91; [macOS] Text drag and drop

From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#30929: closed (26.0.91; [macOS] Text drag and drop does not work)
Date: Thu, 10 Jan 2019 19:25:03 +0000

Your message dated Thu, 10 Jan 2019 19:23:52 +0000
with message-id <address@hidden>
and subject line Re: bug#30929: 26.0.91; Text drag and drop does not work
has caused the debbugs.gnu.org bug report #30929,
regarding 26.0.91; [macOS] Text drag and drop does not work
to be marked as done.

(If you believe you have received this mail in error, please contact

30929: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=30929
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 26.0.91; Text drag and drop does not work Date: Sun, 25 Mar 2018 01:28:11 +1300 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.91 (darwin)
On MacOS text drag-n-drop does not work out of the box. Also a dnd 
event seems to be bound to different functions depending on modifier 

Emacs -Q

C-h v ns-command-modifier -> "It's value is super"

C-h k <drag and drop external text> 
  -> "<M-s-drag-n-drop> is undefined"

(setq ns-command-modifier 'none)
C-h k <drag and drop external text>
  -> "<M-drag-n-drop> at that spot runs the command

(setq ns-command-modifier 'control)
C-h k <drag and drop external text>
  -> "<C-M-drag-n-drop> at that spot runs the command


In GNU Emacs 26.0.91 (build 1, x86_64-apple-darwin17.4.0, NS appkit-1561.20 
Version 10.13.3 (Build 17D102))
 of 2018-03-22 built on jupiter.local
Repository revision: f8cad16bb3272a8069b3008019f9d18516aef1a5
Windowing system distributor 'Apple', version 10.3.1561
Recent messages:
Opening nnimap server on Office365...
Opening connection to localhost via shell...
Opening connection to localhost...done
Opening nnimap server on Office365...done
Opening nntp server on Gmane...done
1 new newsgroup has arrived
Checking new news...
Reading active file via nnnil...done
Reading active file via nndraft...done
Checking new news...done

Configured using:
 'configure --with-gnutls=no'

Configured features:

Important settings:
  value of $LANG: en_NZ.UTF-8
  locale-coding-system: utf-8-unix

Major mode: Text

Minor modes in effect:
  savehist-mode: t
  global-eldoc-mode: t
  mouse-wheel-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  visual-line-mode: t
  transient-mark-mode: t

Load-path shadows:
None found.

(shadow gnus-cite sort mail-extr nnir emacsbug sendmail gnus-demon
nndraft nnmh cl-extra help-mode utf-7 network-stream nsm auth-source
cl-seq eieio eieio-core cl-macs eieio-loaddefs starttls nnfolder nnnil
gnus-agent gnus-srvr gnus-score score-mode nnvirtual gnus-msg gnus-art
mm-uu mml2015 mm-view mml-smime smime dig mailcap nntp gnus-cache
gnus-sum gnus-group gnus-undo gnus-start gnus-cloud nnimap nnmail
mail-source tls gnutls utf7 netrc nnoo parse-time gnus-spec gnus-int
gnus-range message rmc puny seq byte-opt bytecomp byte-compile cconv
format-spec rfc822 mml mml-sec password-cache epa derived epg epg-config
mm-decode mm-bodies mm-encode mail-parse rfc2231 mailabbrev gmm-utils
mailheader gnus-win gnus nnheader gnus-util rmail rmail-loaddefs rfc2047
rfc2045 ietf-drums mail-utils mm-util mail-prsvr wid-edit time dired-x
easymenu dired dired-loaddefs pcase savehist easy-mmode iso-transl
edmacro kmacro cl-loaddefs cl-lib gv plain-theme time-date tooltip eldoc
electric uniquify ediff-hook vc-hooks lisp-float-type mwheel term/ns-win
ns-win ucs-normalize mule-util term/common-win tool-bar dnd fontset
image regexp-opt fringe tabulated-list replace newcomment text-mode
elisp-mode lisp-mode prog-mode register page menu-bar rfn-eshadow
isearch timer select scroll-bar mouse jit-lock font-lock syntax facemenu
font-core term/tty-colors frame cl-generic cham georgian utf-8-lang
misc-lang vietnamese tibetan thai tai-viet lao korean japanese eucjp-ms
cp51932 hebrew greek romanian slovak czech european ethiopic indian
cyrillic chinese composite charscript charprop case-table epa-hook
jka-cmpr-hook help simple abbrev obarray minibuffer cl-preloaded nadvice
loaddefs button faces cus-face macroexp files text-properties overlay
sha1 md5 base64 format env code-pages mule custom widget
hashtable-print-readable backquote kqueue cocoa ns lcms2 multi-tty
make-network-process emacs)

Memory information:
((conses 16 282192 18056)
 (symbols 48 28457 1)
 (miscs 40 54 283)
 (strings 32 54201 2932)
 (string-bytes 1 1603692)
 (vectors 16 43788)
 (vector-slots 8 823234 17468)
 (floats 8 217 385)
 (intervals 56 246 0)
 (buffers 992 16))

--- End Message ---
--- Begin Message --- Subject: Re: bug#30929: 26.0.91; Text drag and drop does not work Date: Thu, 10 Jan 2019 19:23:52 +0000 User-agent: Mutt/1.10.1 (2018-07-13)
On Mon, Jan 07, 2019 at 11:38:33PM +1300, Nick Helm wrote:
> I like the default modifier actions - they match how drag and drop works
> on my other apps. I was worried having the modifiers independent of the
> Emacs modifiers might be a bit confusing with non-default bindings, but
> in practice it doesn't cause me any trouble.


> I also tried as many different dnd operations as I could think of. They
> all worked as expected except one - when I try to open a malformed URL
> Emacs creates a spurious buffer and freezes momentarily (C-g to clear).
> Specifically, I selected the text "file://~/test.txt" in TextEdit.app
> and dropped it into Emacs with Alt/Opt held down. Properly formed URLs
> work as expected and open the file.

I’ve dug into this a bit and I think that’s actually a valid URL as
far as Emacs is concerned. I’m not sure what protocol it’s trying to
use, but it matches the form file://hostname/filename. I assume the
freeze you see is it doing a lookup and if left long enough it will
time out (although it’s an extraordinarily long timeout if true).

I’ll push this to master now.
Alan Third

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]