emacs-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#34819: closed (26.1; Blank help-echo tooltips for


From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#34819: closed (26.1; Blank help-echo tooltips for mode line menus)
Date: Sun, 30 Jun 2019 06:32:02 +0000

Your message dated Sun, 30 Jun 2019 15:31:23 +0900
with message-id <address@hidden>
and subject line Re: bug#34819: 26.1; Blank help-echo tooltips for mode line 
menus
has caused the debbugs.gnu.org bug report #34819,
regarding 26.1; Blank help-echo tooltips for mode line menus
to be marked as done.

(If you believe you have received this mail in error, please contact
address@hidden.)


-- 
34819: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=34819
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 26.1; Blank help-echo tooltips for mode line menus Date: Tue, 12 Mar 2019 12:45:58 +1300 User-agent: Orcon Webmail
Following from:
https://lists.gnu.org/archive/html/emacs-devel/2019-03/msg00324.html

Recipe from emacs -Q (and --with-x-toolkit=lucid)

* M-x text-mode
* Mouse 1 click on "Text" in the mode line to open the menu
* Hover over any of the menu items until the tooltip appears

For me, this produces tooltips of the appropriate dimensions, but the
text itself is not visible.

When I use the top menu bar instead of the mode line, the tooltip text
is visible.

I note also that if I simply hover over "Text" in the mode line, the
"Major mode" tooltip appears with visible text; however if I click-and-
hold the mouse button *before* the tooltip has had time to appear, then
it will be blank when it does appear (over the top of the menu).


-Phil




In GNU Emacs 26.1 (build 1, x86_64-pc-linux-gnu, X toolkit, Xaw scroll bars)
 of 2018-10-23 built on hal
Windowing system distributor 'The X.Org Foundation', version 11.0.11906000
System Description:     Ubuntu 18.04.2 LTS

Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.
(New file)
Using vacuous schema
Quit [2 times]
Configured using:
 'configure --prefix=/home/phil/emacs/26/26.1/usr/local
 --with-x-toolkit=lucid --without-sound'

Configured features:
XPM JPEG TIFF GIF PNG RSVG IMAGEMAGICK DBUS GSETTINGS NOTIFY GNUTLS
LIBXML2 FREETYPE XFT ZLIB TOOLKIT_SCROLL_BARS LUCID X11 THREADS LCMS2

Important settings:
  value of $LANG: en_NZ.UTF-8
  locale-coding-system: utf-8-unix

Major mode: nXML

Minor modes in effect:
  tooltip-mode: t
  global-eldoc-mode: t
  electric-indent-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Load-path shadows:
None found.

Features:
(shadow sort mail-extr emacsbug message rmc puny format-spec rfc822 mml
mml-sec password-cache epa derived epg epg-config gnus-util rmail
rmail-loaddefs mm-decode mm-bodies mm-encode mail-parse rfc2231
mailabbrev gmm-utils mailheader sendmail rfc2047 rfc2045 ietf-drums
mm-util mail-prsvr mail-utils rng-xsd xsd-regexp rng-cmpct rng-nxml
rng-valid rng-loc rng-uri rng-parse nxml-parse rng-match rng-dt rng-util
rng-pttrn nxml-ns easymenu nxml-mode nxml-outln nxml-rap sgml-mode seq
byte-opt gv bytecomp byte-compile cconv dom cl-loaddefs cl-lib nxml-util
nxml-enc xmltok dired dired-loaddefs advice elec-pair time-date
mule-util tooltip eldoc electric uniquify ediff-hook vc-hooks
lisp-float-type mwheel term/x-win x-win term/common-win x-dnd tool-bar
dnd fontset image regexp-opt fringe tabulated-list replace newcomment
text-mode elisp-mode lisp-mode prog-mode register page menu-bar
rfn-eshadow isearch timer select scroll-bar mouse jit-lock font-lock
syntax facemenu font-core term/tty-colors frame cl-generic cham georgian
utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao korean
japanese eucjp-ms cp51932 hebrew greek romanian slovak czech european
ethiopic indian cyrillic chinese composite charscript charprop
case-table epa-hook jka-cmpr-hook help simple abbrev obarray minibuffer
cl-preloaded nadvice loaddefs button faces cus-face macroexp files
text-properties overlay sha1 md5 base64 format env code-pages mule
custom widget hashtable-print-readable backquote dbusbind inotify lcms2
dynamic-setting system-font-setting font-render-setting x-toolkit x
multi-tty make-network-process emacs)

Memory information:
((conses 16 114978 10197)
 (symbols 48 22012 1)
 (miscs 40 116 126)
 (strings 32 34678 2181)
 (string-bytes 1 892076)
 (vectors 16 17344)
 (vector-slots 8 521397 14092)
 (floats 8 68 61)
 (intervals 56 338 0)
 (buffers 992 17))




--- End Message ---
--- Begin Message --- Subject: Re: bug#34819: 26.1; Blank help-echo tooltips for mode line menus Date: Sun, 30 Jun 2019 15:31:23 +0900 User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI-EPG/1.14.7 (Harue) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 EasyPG/1.0.0 Emacs/25.3 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)
On Wed, 26 Jun 2019 21:56:13 +0900,
Phil Sainty wrote:
> 
> On 20/06/19 11:04 PM, address@hidden wrote:
> > I think the patch I posted previously does the right thing.
> > Please try it.
> 
> Thanks; I've just built and tested with this patch, and it does
> indeed seem to resolve the problem.
> 
> I'm not able to review the code change, but all my previous test
> cases are now displaying their tooltips correctly.

Thanks for testing.  I've pushed the patch to master as 82d6b390b5e
(flush_frame part) and 4a5a74a07ff (inhibit-double-buffering part).
Closing the bug.

                                     YAMAMOTO Mitsuharu
                                address@hidden


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]