emacs-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debbugs-tracker] bug#22442: closed (25.0.50; --with-cairo does not disp


From: GNU bug Tracking System
Subject: [debbugs-tracker] bug#22442: closed (25.0.50; --with-cairo does not display PNG on GNU/Linux)
Date: Sun, 30 Jun 2019 09:06:02 +0000

Your message dated Sun, 30 Jun 2019 18:05:45 +0900
with message-id <address@hidden>
and subject line Re: bug#21110: 25.0.50; Images viewed with Image[Imagemagick] 
mode are garbled
has caused the debbugs.gnu.org bug report #21110,
regarding 25.0.50; --with-cairo does not display PNG on GNU/Linux
to be marked as done.

(If you believe you have received this mail in error, please contact
address@hidden.)


-- 
21110: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=21110
GNU Bug Tracking System
Contact address@hidden with problems
--- Begin Message --- Subject: 25.0.50; --with-cairo does not display PNG on GNU/Linux Date: Sat, 23 Jan 2016 00:27:08 -0800 User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1 To reproduce the problem, configure Emacs --with-cairo, and then run these shell commands:

wget https://upload.wikimedia.org/wikipedia/commons/f/f5/All_palaeotemps.png
emacs -Q All_palaeotemps.png

Emacs shows a blank (or sometimes garbled) screen instead of the image.

I think the problem is that lookup_rgb_color is returning garbage.

Here are more details about the configuration, built on Fedora 23 x86-64:

In GNU Emacs 25.0.50.55 (x86_64-unknown-linux-gnu, GTK+ Version 3.18.6, cairo version 1.14.2)
 of 2016-01-22 built on penguin.cs.ucla.edu
Repository revision: 27a0919cde7a6dce93aeba63b5ce7d0834f48531
Configured using:
 'configure --enable-gcc-warnings --with-cairo'

Configured features:
XPM JPEG TIFF GIF PNG RSVG CAIRO IMAGEMAGICK SOUND GPM DBUS GCONF
GSETTINGS NOTIFY ACL LIBSELINUX GNUTLS LIBXML2 FREETYPE M17N_FLT LIBOTF
XFT ZLIB TOOLKIT_SCROLL_BARS GTK3 X11

Important settings:
  value of $LC_ALL: en_US.utf8
  value of $LC_COLLATE: en_US.UTF-8
  value of $LC_CTYPE: en_US.UTF-8
  value of $LC_MESSAGES: en_US.UTF-8
  value of $LANG: C
  locale-coding-system: utf-8-unix



--- End Message ---
--- Begin Message --- Subject: Re: bug#21110: 25.0.50; Images viewed with Image[Imagemagick] mode are garbled Date: Sun, 30 Jun 2019 18:05:45 +0900 User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI-EPG/1.14.7 (Harue) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 EasyPG/1.0.0 Emacs/25.3 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)
On Sun, 30 Jun 2019 17:21:02 +0900,
Robert Marshall wrote:
> 
> YAMAMOTO Mitsuharu writes:
>  > On Thu, 23 Jul 2015 19:01:20 +0900,
>  > Robert Marshall wrote:
>  > > 
>  > > Eli Zaretskii writes:
>  > >  > > Date: Wed, 22 Jul 2015 16:48:55 +0100
>  > >  > > From: Robert Marshall <address@hidden>
>  > >  > > Cc: address@hidden
>  > >  > > 
>  > >  > > Eli Zaretskii writes:
>  > >  > >  > > From: Robert Marshall <address@hidden>
>  > >  > >  > > Date: Wed, 22 Jul 2015 11:31:35 +0100
>  > >  > >  > > 
>  > >  > >  > > I ran emacs -Q imagefile.png
>  > >  > >  > > and on viewing the buffer it consists of garbage which appears 
> to be
>  > >  > >  > > assembled from parts of the X display (if required I can 
> produce a screenshot)
>  > >  > >  > > 
>  > >  > >  > > Same problem is apparent with jpg and gifs.
>  > >  > >  > 
>  > >  > >  > Does the problem go away if you configure without Cairo?
>  > >  > > 
>  > >  > > I'll do a rebuild without Cairo tomorrow
>  > >  > 
>  > >  > Thanks.
>  > > 
>  > > I can confirm that building without Cairo stops the corruption
>  > 
>  > The cairo image support was substantially rewritten on master of the
>  > Emacs git repository.  Could you try it and tell us if you are still
>  > seeing this problem?  Note that the ImageMagick is now disabled by
>  > default, so you would need --with-imagemagick as well as --with-cairo.
>  > 
> 
> Yes a fresh build from git with cairo no longer shows the error. This bug can 
> be closed!
> 
> Thanks

Thanks for testing.  Closing the bug.

                                     YAMAMOTO Mitsuharu
                                address@hidden


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]