[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#18240: closed (24.3; sql-postgres password with cygwin psql)

From: GNU bug Tracking System
Subject: bug#18240: closed (24.3; sql-postgres password with cygwin psql)
Date: Wed, 12 Aug 2020 18:40:03 +0000

Your message dated Wed, 12 Aug 2020 11:39:19 -0700
with message-id 
and subject line Re: Close bugs
has caused the debbugs.gnu.org bug report #18240,
regarding 24.3; sql-postgres password with cygwin psql
to be marked as done.

(If you believe you have received this mail in error, please contact

18240: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18240
GNU Bug Tracking System
Contact help-debbugs@gnu.org with problems
--- Begin Message --- Subject: 24.3; sql-postgres password with cygwin psql Date: Sun, 10 Aug 2014 10:50:16 -0500
Starting emacs 24.3.1 with -Q, sql.el version: 3.4

1. Set sql-postgres-program to psql from cygwin:

     (setq sql-postgres-program "c:/cygwin/bin/psql.exe")

2. Run sql-postgres
3. At prompts, enter user (postgres), database (postgres), server

4. Wait for sql-delay seconds. Login...done.
   Buffer is *SQL* (SQLi[Postgres]:run).
   Prompt for password still not seen.  This is the problem.
   psql prompt not seen.

5. <RET> in that buffer yields

     Password for user postgres:
     psql: fe_sendauth: no password supplied

   and buffer's process dies.

However, repeating steps 2 through 4, doing send-invisible and
entering the password, the process remains and accepts input and
produces psql output (still no psql prompt, though). This does not
work with Windows psql.exe.

This also occurs in emacs-24-20140526-154828-w32-bin where sql.el 3.4
is the default version.

In GNU Emacs 24.3.1 (i386-mingw-nt5.1.2600)
 of 2013-03-17 on MARVIN
Windowing system distributor `Microsoft Corp.', version 5.1.2600
Configured using:
 `configure --with-gcc (4.7) --cflags

Important settings:
  value of $EMACSDATA: C:/emacs-24.3/etc
  value of $EMACSDOC: C:/emacs-24.3/etc
  value of $EMACSLOADPATH: C:/emacs-24.3/site-lisp;C:/emacs-24.3/../site-lisp;C:/emacs-24.3/lisp;C:/emacs-24.3/leim
  value of $EMACSPATH: C:/emacs-24.3/bin
  value of $LANG: ENU
  locale-coding-system: cp1252
  default enable-multibyte-characters: t

Major mode: Lisp Interaction

Minor modes in effect:
  tooltip-mode: t
  mouse-wheel-mode: t
  tool-bar-mode: t
  menu-bar-mode: t
  file-name-shadow-mode: t
  global-font-lock-mode: t
  font-lock-mode: t
  blink-cursor-mode: t
  auto-composition-mode: t
  auto-encryption-mode: t
  auto-compression-mode: t
  line-number-mode: t
  transient-mark-mode: t

Recent input:
<escape> x r e p o r t SPC e m a c s SPC b SPC <re

Recent messages:
For information about GNU Emacs and the GNU system, type C-h C-a.

Load-path shadows:
c:/emacs-24.3/site-lisp/sql hides c:/emacs-24.3/lisp/progmodes/sql

(shadow sort gnus-util mail-extr emacsbug message format-spec rfc822 mml
easymenu mml-sec mm-decode mm-bodies mm-encode mail-parse rfc2231
mailabbrev gmm-utils mailheader sendmail rfc2047 rfc2045 ietf-drums
mm-util mail-prsvr mail-utils time-date tooltip ediff-hook vc-hooks
lisp-float-type mwheel dos-w32 ls-lisp w32-common-fns disp-table w32-win
w32-vars tool-bar dnd fontset image regexp-opt fringe tabulated-list
newcomment lisp-mode register page menu-bar rfn-eshadow timer select
scroll-bar mouse jit-lock font-lock syntax facemenu font-core frame cham
georgian utf-8-lang misc-lang vietnamese tibetan thai tai-viet lao
korean japanese hebrew greek romanian slovak czech european ethiopic
indian cyrillic chinese case-table epa-hook jka-cmpr-hook help simple
abbrev minibuffer loaddefs button faces cus-face macroexp files
text-properties overlay sha1 md5 base64 format env code-pages mule
custom widget hashtable-print-readable backquote make-network-process
w32 multi-tty emacs)

--- End Message ---
--- Begin Message --- Subject: Re: Close bugs Date: Wed, 12 Aug 2020 11:39:19 -0700 User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)
It seems like the intention below was to close this bug.  I'm going to
boldly assume that is correct and close this bug now.

If this conclusion is incorrect, please reply to this email (use "Reply
to all" in your email client) and we can reopen the bug report.

Best regards,
Stefan Kangas

Michael Mauger <mmauger@protonmail.com> writes:

> # placeholder
> close 11481 27.0.50
> # missing prompt-cont-regexp handling
> close 24483 27.0.50
> # postgres password prompt
> tag 18066 + unreproducible moreinfo
> tag 18240 + unreproducible moreinfo
> tag 20288 + unreproducible moreinfo
> tag 20289 + unreproducible moreinfo notabug
> tag 23063 + unreproducible moreinfo
> tag 29105 + unreproducible moreinfo
> tag 3569 + notabug
> close 3569
> close 14759 26.1
> tag 15202 + notabug
> tag 22016 + unreproducible moreinfo
> close 22106 26.1
> close 30247 27.0.50
> thank you
> --
> MICHAEL@MAUGER.COM // FSF and EFF member // GNU Emacs sql.el maintainer

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]