emacs-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#49388: closed ([PATCH 07/21] gnu: Add rust-postgres-protocol-0.6)


From: GNU bug Tracking System
Subject: bug#49388: closed ([PATCH 07/21] gnu: Add rust-postgres-protocol-0.6)
Date: Tue, 13 Jul 2021 12:18:02 +0000

Your message dated Tue, 13 Jul 2021 15:15:49 +0300
with message-id <YO2D9TN+Lxu/NOST@3900XT>
and subject line Re: [bug#49383] [PATCH v2 00/26] Addressing comments
has caused the debbugs.gnu.org bug report #49383,
regarding [PATCH 07/21] gnu: Add rust-postgres-protocol-0.6
to be marked as done.

(If you believe you have received this mail in error, please contact
help-debbugs@gnu.org.)


-- 
49383: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=49383
GNU Bug Tracking System
Contact help-debbugs@gnu.org with problems
--- Begin Message --- Subject: [PATCH 07/21] gnu: Add rust-postgres-protocol-0.6 Date: Sun, 4 Jul 2021 17:31:49 +0100
* gnu/packages/crates-io.scm (rust-postgres-protocol-0.6): New public variable.
---
 gnu/packages/crates-io.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 359b48542d..e998ad334f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32581,6 +32581,39 @@ UDP.")
      "This package provides low level Postgres protocol APIs.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-postgres-protocol-0.6
+  (package
+    (name "rust-postgres-protocol")
+    (version "0.6.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "postgres-protocol" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1wxzs78zvz00bh3bhbbp9hnq9hg77f8h5pzjmcy9481fsdq0ygpz"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-base64" ,rust-base64-0.13)
+         ("rust-byteorder" ,rust-byteorder-1)
+         ("rust-bytes" ,rust-bytes-1)
+         ("rust-fallible-iterator"
+          ,rust-fallible-iterator-0.2)
+         ("rust-hmac" ,rust-hmac-0.10)
+         ("rust-md-5" ,rust-md-5-0.9)
+         ("rust-memchr" ,rust-memchr-2)
+         ("rust-rand" ,rust-rand-0.8)
+         ("rust-sha2" ,rust-sha2-0.9)
+         ("rust-stringprep" ,rust-stringprep-0.1))))
+    (home-page
+      "https://github.com/sfackler/rust-postgres";)
+    (synopsis "Low level Postgres protocol APIs")
+    (description "Low level Postgres protocol APIs")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-postgres-shared-0.4
   (package
     (name "rust-postgres-shared")
-- 
2.32.0




--- End Message ---
--- Begin Message --- Subject: Re: [bug#49383] [PATCH v2 00/26] Addressing comments Date: Tue, 13 Jul 2021 15:15:49 +0300
Patches pushed. Some of the patches which changed some crates from using
rust-cipher-0.2 to 0.3 I skipped since they no longer built after the
change.

Thanks!

-- 
Efraim Flashner   <efraim@flashner.co.il>   אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

Attachment: signature.asc
Description: PGP signature


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]