emacs-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#49573: closed (13.0.6; [Error: No Content found] inside \verb tags)


From: GNU bug Tracking System
Subject: bug#49573: closed (13.0.6; [Error: No Content found] inside \verb tags)
Date: Thu, 15 Jul 2021 20:31:03 +0000

Your message dated Thu, 15 Jul 2021 22:19:59 +0200
with message-id <874kcv2ucl.fsf@gnu.org>
and subject line Re: bug#49573: 13.0.6; [Error: No Content found] inside \verb 
tags
has caused the debbugs.gnu.org bug report #49573,
regarding 13.0.6; [Error: No Content found] inside \verb tags
to be marked as done.

(If you believe you have received this mail in error, please contact
help-debbugs@gnu.org.)


-- 
49573: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=49573
GNU Bug Tracking System
Contact help-debbugs@gnu.org with problems
--- Begin Message --- Subject: 13.0.6; [Error: No Content found] inside \verb tags Date: Thu, 15 Jul 2021 14:40:56 +0200
if I use TeX-fold mode on this line
(\verb|\section...|),\verb|(\subsection...|), etc.
I get Error: Content not found on the \section... part.
I don't know if this is an user error, but I thought I just report this
here.

Please feel free to redirect me to somewhere more appropriate.

Emacs  : GNU Emacs 27.2 (build 1, x86_64-pc-linux-gnu, GTK+ Version 3.24.27, 
cairo version 1.17.4)
 of 2021-03-26
Package: 13.0.6

current state:
==============
(setq
 AUCTeX-date "2021-04-02"
 window-system 'x
 LaTeX-version "2e"
 TeX-style-path '("~/.emacs.d/auctex" 
"/home/clausi/.emacs.d/.local/straight/build-27.2/auctex/style" 
"/home/clausi/.emacs.d/auctex/.auctex-auto" 
"/home/clausi/.emacs.d/auctex/.auctex-style" ".auctex-auto" ".auctex-style")
 TeX-auto-save t
 TeX-parse-self t
 TeX-master t
 TeX-command-list '(("LatexMk" "latexmk %(-PDF)%S%(mode) %(file-line-error) 
%(extraopts) %t" TeX-run-latexmk nil (plain-tex-mode latex-mode doctex-mode) 
:help "Run LatexMk")
                    ("LatexMk" "latexmk %(-PDF)%S%(mode) %(file-line-error) 
%(extraopts) %t" TeX-run-latexmk nil (plain-tex-mode latex-mode doctex-mode) 
:help "Run LatexMk")
                    ("TeX" "%(PDF)%(tex) %(file-line-error) %`%(extraopts) 
%S%(PDFout)%(mode)%' %(output-dir) %t" TeX-run-TeX nil (plain-tex-mode 
ams-tex-mode texinfo-mode) :help "Run plain TeX")
                    ("LaTeX" "%`%l%(mode)%' %T" TeX-run-TeX nil (latex-mode 
doctex-mode) :help "Run LaTeX") ("Makeinfo" "makeinfo %(extraopts) %(o-dir) %t" 
TeX-run-compile nil (texinfo-mode) :help "Run Makeinfo with Info output")
                    ("Makeinfo HTML" "makeinfo %(extraopts) %(o-dir) --html %t" 
TeX-run-compile nil (texinfo-mode) :help "Run Makeinfo with HTML output")
                    ("AmSTeX" "amstex %(PDFout) %`%(extraopts) %S%(mode)%' 
%(output-dir) %t" TeX-run-TeX nil (ams-tex-mode) :help "Run AMSTeX")
                    ("ConTeXt" "%(cntxcom) --once --texutil %(extraopts) 
%(execopts)%t" TeX-run-TeX nil (context-mode) :help "Run ConTeXt once")
                    ("ConTeXt Full" "%(cntxcom) %(extraopts) %(execopts)%t" 
TeX-run-TeX nil (context-mode) :help "Run ConTeXt until completion")
                    ("BibTeX" "bibtex %(O?aux)" TeX-run-BibTeX nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode context-mode) 
:help "Run BibTeX")
                    ("Biber" "biber %s %(output-dir)" TeX-run-Biber nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help "Run 
Biber") ("View" "%V" TeX-run-discard-or-function t t :help "Run Viewer")
                    ("Print" "%p" TeX-run-command t t :help "Print the file") 
("Queue" "%q" TeX-run-background nil t :help "View the printer queue" :visible 
TeX-queue-command)
                    ("File" "%(o?)dvips %d -o %f " TeX-run-dvips t 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help 
"Generate PostScript file")
                    ("Dvips" "%(o?)dvips %d -o %f " TeX-run-dvips nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help 
"Convert DVI file to PostScript")
                    ("Dvipdfmx" "dvipdfmx %d -o %(O?pdf)" TeX-run-dvipdfmx nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help 
"Convert DVI file to PDF with dvipdfmx")
                    ("Ps2pdf" "ps2pdf %f %(O?pdf)" TeX-run-ps2pdf nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help 
"Convert PostScript file to PDF")
                    ("Glossaries" "makeglossaries %(O?aux)" TeX-run-command nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help "Run 
makeglossaries to create glossary\n     file")
                    ("Index" "makeindex %(O?idx)" TeX-run-index nil 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help "Run 
makeindex to create index file")
                    ("upMendex" "upmendex %(O?idx)" TeX-run-index t 
(plain-tex-mode latex-mode doctex-mode ams-tex-mode texinfo-mode) :help "Run 
upmendex to create index file")
                    ("Xindy" "texindy %s" TeX-run-command nil (plain-tex-mode 
latex-mode doctex-mode ams-tex-mode texinfo-mode) :help "Run xindy to create 
index file")
                    ("Check" "chktex -v6 -H %s" TeX-run-compile nil 
(latex-mode) :help "Check LaTeX file for correctness") ("ChkTeX" "chktex -v6 
%s" TeX-run-compile nil (latex-mode) :help "Check LaTeX file for common 
mistakes")
                    ("Spell" "(TeX-ispell-document \"\")" TeX-run-function nil 
t :help "Spell-check the document") ("Clean" "TeX-clean" TeX-run-function nil t 
:help "Delete generated intermediate files")
                    ("Clean All" "(TeX-clean t)" TeX-run-function nil t :help 
"Delete generated intermediate and output files") ("Other" "" TeX-run-command t 
t :help "Run an arbitrary command"))
 )



--- End Message ---
--- Begin Message --- Subject: Re: bug#49573: 13.0.6; [Error: No Content found] inside \verb tags Date: Thu, 15 Jul 2021 22:19:59 +0200 User-agent: mu4e 1.5.13; emacs 28.0.50
Claus-Peter K├Ąpplinger <clausi9860@gmail.com> writes:

Hi Claus-Peter,

> if I use TeX-fold mode on this line
> (\verb|\section...|),\verb|(\subsection...|), etc.
> I get Error: Content not found on the \section... part.
> I don't know if this is an user error, but I thought I just report
> this here.

It is a user error.  When used on a macro, TeX-fold would fold
\foo{Something} to just the content, i.e., Something.  In your example,
\section and \subsection don't have an argument but it's mandatory.  So
write your example as \verb|\section{...}| or something alike.

I'm closing this issue.

Bye,
Tassilo


--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]