[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#57141: closed (29.0.50; Most emoji not displaying in PGTK emacs)

From: GNU bug Tracking System
Subject: bug#57141: closed (29.0.50; Most emoji not displaying in PGTK emacs)
Date: Fri, 12 Aug 2022 05:39:02 +0000

Your message dated Fri, 12 Aug 2022 08:38:11 +0300
with message-id <83tu6inhrw.fsf@gnu.org>
and subject line Re: bug#57141: 29.0.50; Most emoji not displaying in PGTK emacs
has caused the debbugs.gnu.org bug report #57141,
regarding 29.0.50; Most emoji not displaying in PGTK emacs
to be marked as done.

(If you believe you have received this mail in error, please contact

57141: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=57141
GNU Bug Tracking System
Contact help-debbugs@gnu.org with problems
--- Begin Message --- Subject: 29.0.50; Most emoji not displaying in PGTK emacs Date: Thu, 11 Aug 2022 14:10:25 +0000
I use emacs under wayland (sway) with PGTK and native compilation,
compiled from master. However, I found that in this configuration, at
least in my recent builds, unicode emoji are not properly displayed.
E.g. if I call `emoji-list', most emoji are not shown at all, except
very basic emoji like "Smileys > affection." If I insert a unicode
emoji, I just see a unicode placeholder. Calling `describe-char' on the
"Smileys > smiling" emoji from the *Emoji* buffer gives gives me:

               position: 65 of 2529 (3%), column: 0
               character: C-j (displayed as C-j) (codepoint 10, #o12, #xa)
               charset: ascii (ASCII (ISO646 IRV))
   code point in charset: 0x0A
               script: latin
               syntax:          which means: whitespace
               to input: type "C-x 8 RET a" or "C-x 8 RET LINE FEED (LF)"
           buffer code: #x0A
               file code: not encodable by coding system nil
               display: no font available

I tried using a different emoji font via customizing the emoji face,
where I set the font family to "JoyPixels", but this resulted in emacs crashing.

I could not find an existing ticket with "emoji" in the subject that
fits my symptoms, but maybe I didn't look properly or this is a symptom
of another known bug. Or I just misconfigured something on my system
which results in problems with the coding system or something that
happens due to my compilation options. Anyway, I don't know what else to
do to fix this on my own, so I would be happy for hints of if this can
be fixed somehow.

Best regards,
Michael Eliachevitch

In GNU Emacs 29.0.50 (build 2, x86_64-pc-linux-gnu, GTK+ Version 3.24.34, cairo 
version 1.17.6)
of 2022-08-11 built on e490
Repository revision: 89f51673792b13ae0d1b93d0bf8e35d452693c9c
Repository branch: makepkg
System Description: Arch Linux

Configured using:
'configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib
--localstatedir=/var --mandir=/usr/share/man --with-gameuser=:games
--with-modules --without-libotf --without-m17n-flt --without-gconf
--enable-link-time-optimization --with-native-compilation
--with-xinput2 --with-pgtk --without-xaw3d --with-sound=no
--with-xwidgets --without-gpm --without-compress-install
'CFLAGS=-march=native -mtune=generic -O3 -pipe -fno-plt -fexceptions
-Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security
-fstack-clash-protection -fcf-protection'

Configured features:

Important settings:
 value of $LC_ALL: C
 value of $LC_COLLATE: C.UTF-8
 value of $LC_CTYPE: en_US.UTF-8
 value of $LC_MESSAGES: en_US.UTF-8
 value of $LC_MONETARY: de_DE.UTF-8
 value of $LC_NUMERIC: en_US.UTF-8
 value of $LC_TIME: de_DE.UTF-8
 value of $LANG: en_US.UTF-8
 value of $XMODIFIERS: @im=fcitx
 locale-coding-system: nil

Major mode: Lisp Interaction

Minor modes in effect:
 tooltip-mode: t
 global-eldoc-mode: t
 eldoc-mode: t
 show-paren-mode: t
 electric-indent-mode: t
 mouse-wheel-mode: t
 tool-bar-mode: t
 menu-bar-mode: t
 file-name-shadow-mode: t
 global-font-lock-mode: t
 font-lock-mode: t
 blink-cursor-mode: t
 line-number-mode: t
 indent-tabs-mode: t
 transient-mark-mode: t
 auto-composition-mode: t
 auto-encryption-mode: t
 auto-compression-mode: t

Load-path shadows:
None found.

(shadow sort mail-extr emacsbug message mailcap yank-media puny dired
dired-loaddefs rfc822 mml mml-sec password-cache epa derived epg rfc6068
epg-config gnus-util text-property-search time-date mm-decode mm-bodies
mm-encode mail-parse rfc2231 mailabbrev gmm-utils mailheader sendmail
rfc2047 rfc2045 ietf-drums mm-util mail-prsvr mail-utils emoji-labels
emoji generate-lisp-file multisession sqlite transient comp comp-cstr
warnings icons subr-x rx cl-seq format-spec edmacro kmacro eieio
byte-opt bytecomp byte-compile cconv eieio-core cl-macs gv cl-extra
help-mode cl-loaddefs cl-lib rmc iso-transl tooltip eldoc paren electric
uniquify ediff-hook vc-hooks lisp-float-type elisp-mode mwheel
term/pgtk-win pgtk-win term/common-win pgtk-dnd tool-bar dnd fontset
image regexp-opt fringe tabulated-list replace newcomment text-mode
lisp-mode prog-mode register page tab-bar menu-bar rfn-eshadow isearch
easymenu timer select scroll-bar mouse jit-lock font-lock syntax
font-core term/tty-colors frame minibuffer nadvice seq simple cl-generic
indonesian philippine cham georgian utf-8-lang misc-lang vietnamese
tibetan thai tai-viet lao korean japanese eucjp-ms cp51932 hebrew greek
romanian slovak czech european ethiopic indian cyrillic chinese
composite emoji-zwj charscript charprop case-table epa-hook
jka-cmpr-hook help abbrev obarray oclosure cl-preloaded button loaddefs
faces cus-face macroexp files window text-properties overlay sha1 md5
base64 format env code-pages mule custom widget keymap
hashtable-print-readable backquote threads xwidget-internal dbusbind
inotify dynamic-setting system-font-setting font-render-setting cairo
gtk pgtk lcms2 multi-tty make-network-process native-compile emacs)

Memory information:
((conses 16 118945 18632)
(symbols 48 21096 1)
(strings 32 102059 1853)
(string-bytes 1 2486759)
(vectors 16 26117)
(vector-slots 8 1148486 18229)
(floats 8 39 31)
(intervals 56 744 0)
(buffers 992 13))

Michael Eliachevitch
Public PGP Key: 

--- End Message ---
--- Begin Message --- Subject: Re: bug#57141: 29.0.50; Most emoji not displaying in PGTK emacs Date: Fri, 12 Aug 2022 08:38:11 +0300
> From: Michael Eliachevitch <m.eliachevitch@posteo.de>
> Cc: 57141@debbugs.gnu.org
> Date: Thu, 11 Aug 2022 18:54:29 +0000
> I figured out this issue, it was due to my custom font configuration in 
> ~/.config/fontconfig/fonts.conf'. When deleting that file, emojis display and 
> I can also set the face- and frame-fonts to emoji fonts. Probably it's just 
> broken, but I think it's still possible that it's formally correct, but the 
> hinting and aliasing rules that it specifies cause some bug down the line. 
> Feel free to close this, though if anyone is interested, I attached the file.
> I also tried applying the suggested patch from bug#57066, but saw no 
> difference: Without the custom fonts.conf the emoji display works well 
> whether the patch is applied or not . With the custom fonts.conf the patch 
> doesn't fix the issue.
> Thanks so much for the help Eli! I'm glad to have this finally solved as I'm 
> seeing more and more emacs users and packages starting to use unicode emoji.

Thank you for telling us.  I'm therefore closing this bug.

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]