[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building fails on Debian woody because of stupid autoconf wrapper

From: Andreas Schwab
Subject: Re: Building fails on Debian woody because of stupid autoconf wrapper
Date: 18 Oct 2001 16:21:24 +0200
User-agent: Gnus/5.090003 (Oort Gnus v0.03) Emacs/21.0.107

Eli Zaretskii <address@hidden> writes:

|> On 18 Oct 2001, Andreas Schwab wrote:
|> > |> Yes, but if someone does want to regenerate configure, they might be in 
|> > |> trouble, I think.
|> > 
|> > Why?  Autoconf 2.52 is an officially released version.  Those who modify
|> > configure.in must know what they are doing.
|> I was thinking about the situation described by Kai, where both versions 
|> of Autoconf are installed.  I understand that what you suggested might 
|> cause the wrong version to be chosen.

I don't think so, since Kay's point was that the comment in aclocal.m4
specified AC_PREREQ(2.14) (a version that was never released) which
triggered the use of autoconf 2.5x with Debian.  Putting AC_PREREQ(2.52)
in configure.in (and removing aclocal.m4 at the same time) would just
manifest that.  Since configure.in is already prepared for autoconf 2.5x
there should be no problems doing the switch.


Andreas Schwab                                  "And now for something
address@hidden                          completely different."
SuSE Labs, SuSE GmbH, Schanzäckerstr. 10, D-90443 Nürnberg
Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5

reply via email to

[Prev in Thread] Current Thread [Next in Thread]