[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: define-key acting strange..

From: D. Goel
Subject: Re: define-key acting strange..
Date: 24 May 2002 01:31:31 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1


>     It now seems that Emacs is not really frozen. It is just that all (all
>     that i tried) of the C- commands, M- commands and number-keys beep at
>     you...
> I see no reason why those bindings in key-translation-map SHOULD have this
> effect, so I think it is really an Emacs bug.  Would you please pick
> one character -- how about Ctrl-a? -- and determine exactly why it is not
> recognized?  These bindings in key-translation-map ought to have no effect
> on the processing of Ctrl-a.

okay, i shall do as you suggested.  

To the list: BTW, this 'gdb emacs' will be a huge learning curve for
me, and i will bug folks (is this the right forum or should i try
g.e.help?) for help.. instead, if a GDB expert would like to pick this
bug-report up, that would be cool :).. 

If not, here's the first snafu i ran into (i get to my umd.edu unix
account through an ssh over QVT/Term on win2000)---->

| student1:~: cd emacs
| student1:~/emacs: cd src
| student1:~/emacs/src: gdb /usr/local/gnu/bin/emacs21
| GNU gdb 4.18
| Copyright 1998 Free Software Foundation, Inc.
| GDB is free software, covered by the GNU General Public License, and
| you are
| welcome to change it and/or distribute copies of it under certain
| conditions.
| Type "show copying" to see the conditions.
| There is absolutely no warranty for GDB.  Type "show warranty" for
| details.
| This GDB was configured as "alpha-dec-osf4.0b"...
| Environment variable "DISPLAY" not defined.
| TERM = vt220
| Breakpoint 1 at 0x1201186e8: file emacs.c, line 389.
| Breakpoint 2 at 0x1200ed824: file xterm.c, line 12015.
| (gdb)
gdb seems to have stopped..  typing 'continue' doesn't help :(.. is
this because i don't have display available?  But i can't run Xwindows
here.. :(

BTW, This directory emacs/src above is indeed the directory from
emacs21 is built.. this is the one containing dired.c, for
example.. and if i chase links, its fullname is:

the problem above seems pretty emacs-source specific.. but if this it
OT, apologies..

D                                  <http://www.glue.umd.edu/~deego/>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]