[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp: ssh method broken

From: Andreas Schwab
Subject: Re: tramp: ssh method broken
Date: Wed, 21 Aug 2002 17:40:43 +0200
User-agent: Gnus/5.090007 (Oort Gnus v0.07) Emacs/21.3.50 (ia64-suse-linux)

address@hidden (Kai Großjohann) writes:

|> Andreas Schwab <address@hidden> writes:
|> > The ssh method seems to be broken for big files.  Files that are bigger
|> > than about 100K often (but not always) end up being empty.  Files that are
|> > even bigger are always retrieved as empty.  Also, remotely saving files
|> > does not work at all, tramp is constantly trying to reinitialize the
|> > shell.  By contrast, the scp method is working just fine.
|> I tried to reproduce both problems, but I could only reproduce the
|> saving problem.  Is it fixed now?

No.  The following messages are repeated infinitely:

tramp: Initializing remote shell
tramp: Waiting 30s for remote `/bin/sh' to come up...
tramp: Setting up remote shell environment
tramp: Determining coding system
tramp: Waiting 30s for `HISTFILE=$HOME/.tramp_history; HISTSIZE=1'
tramp: Waiting 30s for `set +o vi +o emacs'
tramp: Waiting 30s for `unset MAIL MAILCHECK MAILPATH'
tramp: Waiting 30s for `unset CDPATH'
tramp: Setting shell prompt
tramp: Opening connection at neodym using ssh...
tramp: Processing actions
tramp: Waiting 60s for prompt from remote shell
tramp: Looking for pattern ^.*\([pP]assword\|passphrase.*\):
tramp: Looking for pattern .*ogin: *
tramp: Looking for pattern ^[^#$%>
]*[#$%>] *
tramp: Looking for pattern ^.*\(Connection \(?:\(?:clo\|refu\)sed\)\|Host key 
verification failed\.\|Login \(?:[Ii]ncorrect\)\|Name or service not 
known\|\(?:Permission denied\|Sorry, try again\)\.\).*\|^.*\(Received signal 
tramp: Looking for pattern Are you sure you want to continue connecting 
(yes/no)\? *
tramp: Looking for pattern ^.*\([pP]assword\|passphrase.*\):
tramp: Looking for pattern .*ogin: *
tramp: Looking for pattern ^[^#$%>
]*[#$%>] *
tramp: Found remote shell prompt.

|> Maybe it also works now to find large remote files?

I still sometimes get no data, but it eventually succeeds when repeated.
Once I got into the loop above I don't seem to be able to use tramp w/ ssh
at all until I kill the *tramp/ssh ...* buffer.


Andreas Schwab, SuSE Labs, address@hidden
SuSE Linux AG, Deutschherrnstr. 15-19, D-90429 Nürnberg
Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]