[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest 21.3 CVS and MS Windows

From: Juanma Barranquero
Subject: Re: Latest 21.3 CVS and MS Windows
Date: Thu, 06 Feb 2003 11:01:49 +0100

On Thu, 06 Feb 2003 09:25:59 +0100, Frank Schmitt <address@hidden> wrote:

> First I tried to build using MS Visual C++ 6.0. I said "configure.bat
> --with-ms-vc"

 --with-msvc, I suppose.

> and then said nmake but got an error message telling that
> essential Lisp files would be missing and that I should either create
> abbrev.elc somehow or run nmake bootstrap.
> I then said "nmake bootstrap", this took ages but worked.

That's the right procedure. First time you *must* do a bootstrap.

> I then said
> "nmake install" however something seems to be broken about creation of
> Info files because when i fire up info, I get the usual top node, but no
> matter on which menu item I go, I get the error message "Info file foo
> does not exist.".

Is not broken, it's simply not supported, because most Windows users
don't have the tools to build info files. You can get a working makeinfo
from http://www.simtel.net/pub/djgpp/v2gnu/ (get txi42b.zip) and
manually build the info files (that's what I do). If you get make errors
try taking Cygwin bin directory from the PATH.

(Lack of support for building info files hasn't been a problem till now
because prebuilt binaries come with prebuilt info files too.)

> Configure found all external libraries except the gif
> libraries and nmake gave me an Emacs which was able of displaying
> XPM's. However (image-type-available-p 'tif) (or 'tiff) evaluates to
> nil

There are some interactions between the libraries (libtiff.dll needs
libjpeg.dll, etc.), and not all releases work well togheter. I'm using:

 libjpeg-6b (includes librle.dll)

(from GnuWin32) which seem to be nice with each other.

> trying to display a jpeg results in an empty square of the size of a character

When that happened to me, it was the result of a mismatch between the
libraries (a libjpeg.dll that couldn't find the corresponding librle.dll).

> and trying to display a png makes Emacs crash, no matter if I use
> libpng-1.2.4 or libpng-1.0.13.

That's probably a bug. Were you compiling Emacs with optimizations?
Currently, images work well for me with MSVC 6.0 and --no-opt, but I get
crashes with TIFF and PNG files when optimization is enabled.

Don't forget that image support on Windows is still experimental. Any
information you can gather about the crashes could be useful.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]