[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest 21.3 CVS and MS Windows

From: Jason Rumney
Subject: Re: Latest 21.3 CVS and MS Windows
Date: 06 Feb 2003 19:49:10 +0000
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

Frank Schmitt <address@hidden> writes:

> I then said "nmake bootstrap", this took ages but worked. I then said
> "nmake install" however something seems to be broken about creation of
> Info files

That is a known bug with the W32 build scripts.

> I said
> ./configure.bat --with-gcc --no-cygwin --cflags 
> -I/win/g/Programme/gnuwin32/include/
> which worked
> but saying make (or make bootstrap) results in
> [Please ignore a syntax error on the next line - it is intentional]
> Syntax error: Unterminated quoted string
> Using /bin/sh.exe as shell.
> gcc -o oo-spd/i386/addpm.exe \
>            -g -mno-cygwin  oo-spd/i386/addpm.o   -ladvapi32 -luser32
> /usr/lib/gcc-lib/i686-pc-mingw32/3.2/../../../../i686-pc-mingw32/bin/ld: 
> cannot open crt2.o: No such file or directory

Your version of make seems to be generating cygwin paths, which is
known to cause problems.  Try the mingw32 port of GNU make instead of
the Cygwin port.  Since gcc is (I assume) a Cygwin program, it is
probably not the cause of this specific failure, but it will cause
problems later in the build process once you get beyond this.
I think the problem here may be that you do not have the mingw32
runtime libraries installed, which are necessary for --no-cygwin builds.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]