[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: no font shown with tamil.el

From: Raja R Harinath
Subject: Re: no font shown with tamil.el
Date: Thu, 13 Feb 2003 16:50:20 -0600
User-agent: Gnus/5.090016 (Oort Gnus v0.16) Emacs/21.3.50


"Robert J. Chassell" <address@hidden> writes:

> Handa-san's suggestion, involving the `mkfontdir' command, worked so I
> have not tried yours.  (I have appended yours to remind people which
> it is.)

I assumed that your fonts were setup completely.  I missed that you
didn't have 'mkfontdir' there.  

> Which suggestion would be better in the long run?  

My suggestion is subordinate :-)  You can't do anything useful
without the 'mkfontdir'.

> For example, I start my regular Emacs under GDB with the command:
>     run -q -l ~bob/.emacs-21 -bg darkblue -fg white \
>         -fn '-Misc-Fixed-Medium-R-Normal--20-200-75-75-C-100-ISO8859-1' \
>         -geometry 80x52+120+45 \
>         -name 'GNU Emacs 21'
> The `frame-parameters' function tells me    (font . "10x20"))
> No `fontset-startup' or `fontset-default'.  Evidentally, the `-fn'
> argument does not define one.  Moreover
>     (query-fontset (frame-parameter nil 'font))
> returns nil in my regular Emacs.  Am I right in thinking I have no
> default or startup fontset?

I think so.  I don't know how this works, either.

> (On the other land, in a plain vanilla Emacs, started under GDB with
> the command:
>     run -q --no-site-file --eval '(blink-cursor-mode 0)'
> the `query-fontset' expression returns
> "-etl-*-medium-r-normal-*-16-*-*-*-*-*-fontset-16".  Does this mean
> that its default fontset is "fontset-16"?)

Looks like it.  In emacs from CVS, I think it is 'fontset-default'.
That fontset is the only one that appears to be prepared to show
tamil/telugu/kannada/... once the corresponding lng-util.el is

>        (let ((current-fontset (query-fontset (frame-parameter nil 'font))))
>          (when current-fontset
>            (load-library "quail/indian")
>            (set-fontset-font current-fontset
>                              (cons (decode-char 'ucs ?\x0900) 
>                                    (decode-char 'ucs ?\x097f))
>                              (cons "*" "iso10646.indian-1"))
>            (mapc
>             (lambda (lsym)
>               (set-fontset-font current-fontset
>                                 (cons (indian-glyph-char 0 lsym)
>                                       (indian-glyph-char 255 lsym))
>                                 (cons "*" (concat (symbol-name lsym) 
> "-cdac"))))
>             indian-script-table)))

This code parallels 'setup-fontset-default' in international/fontset.el.
These glyphsets are not listed in 'x-font-name-charset-alist' and
so aren't setup for all fontsets.

- Hari
Raja R Harinath ------------------------------ address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]