[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

MacOSX: cannot build package (mac/make-package)

From: Martin Fredriksson
Subject: MacOSX: cannot build package (mac/make-package)
Date: Sun, 2 Mar 2003 17:16:54 +0100

Current (march 2 2003) builds ok, using "./configure --without-x --enable-carbon-app". However, the mac/make-package command results in 'sed' errors when running the config.status in the build dir. This happens without any flags to 'make-package' (I run it from the 'mac' dir).

The main error is:

/^VPATH[ ]*=/cvpath % ...": command c expects \ followed by text

I tried to isolate the problem myself, but failed since I am not familiar enough with configure. The problem seems to be that the 'extrasub' "hack" gets used to include 'vpath' support stuff into mac/configure.status, and that something is wrong with 'extrasub' running on my configuration. My config is: OSX 10.2.4 (6I32), Darwin 6.4, using the latest (released) devtools.

I'll gladly assist with more info if necessary. And, I of course appreciate any insight into what I am doing wrong. The problem has existed for at least a couple of weeks; I wanted to try to solve it myself before I reported it.


Martin Fredriksson <address@hidden>, Carlstedt Research & Technology AB
   PGP: Search for ID=0x1573BEC450D630F3 at http://pgpkeys.mit.edu/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]