[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: request for a new function, say, `sequence'

From: Luc Teirlinck
Subject: Re: request for a new function, say, `sequence'
Date: Mon, 24 Mar 2003 19:47:12 -0600 (CST)

Kenichi Handa wrote:
   I'm not sure it is a good idea to extend dotimes and make it
   different from Commong Lisp.

I agree that this would be a bad idea.

I find the name `sequence' for the new function confusing, however,
since it looks so analogous to `list', `string' and `vector', 'making 
(sequence from to type) look like a synonym for:
(type from to).  Would the name `interval' not be better?  After all,
an interval is exactly what the function returns.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]