[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Code cleanup -- inconsistent "width" and "height" etc.

From: Miles Bader
Subject: Re: Code cleanup -- inconsistent "width" and "height" etc.
Date: 10 Apr 2003 10:32:40 +0900

address@hidden (Kim F. Storm) writes:
> Things measured in columns/lines are named as _CANON_WIDTH and
> _CANON_HEIGHT resp., while things measured in pixels are named as

`_CANON_WIDTH' sounds annoyingly redundant; if that's the canonical
representation, then just use `_WIDTH,' and save additional adjectives
for exceptional cases.

Adding unnecessary verbosity simply makes the code more tedious (and
thus harder) to read.

[For the same reason, such adjectives _shouldn't_ be used in cases where
only one representation is possible by definition; e.g., the width of a
character in a font is obviously in pixels, so adding `_pixel' would be
unnecessary and harmful.]

Is it true that nothing can be known?  If so how do we know this?  -Woody Allen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]