[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: utf-translate-cjk-mode question

From: Kai Großjohann
Subject: Re: utf-translate-cjk-mode question
Date: Fri, 02 May 2003 09:22:01 +0200
User-agent: Gnus/5.1002 (Gnus v5.10.2) Emacs/21.3.50 (gnu/linux)

Kenichi Handa <address@hidden> writes:

> In article <address@hidden>, address@hidden (Kai Großjohann) writes:
>> Emacs tells me that it can't encode the Chinese characters, and it
>> tried iso-latin-1 and utf-8 as encodings, and now it's suggesting
>> gb2312 as the encoding to use.
>> Is utf-translate-cjk-mode supposed to enable me to store the file as
>> utf-8?
> Yes, and this bug is my fault.  My previous change to
> find-coding-systems-region-internal was incomplete.  I've
> just installed a fix.  Please try again with the latest

I waited a bit until head would compile again.  This morning, it did,
and I tested, and it works!

Thanks a lot.

>> The second question contains the code itself.  I tried to just copy
>> and paste it from the original defcustom.  But maybe I did something
>> wrong.  After loading all the subst-foo files, there is a let
>> statement that binds the symbol `table'.  But after this, nothing is
>> done with that symbol -- it does not appear to be accessed after
>> being populated.  I also looked in version 1.27 (the last version
>> before my change), and there, too, the symbol `table' does not appear
>> to be accessed.
> This is also my fault.  When I made register-char-codings
> obsolete, I forgot to delete this unnecessary code.

Ah, it's gone now.

And it works to turn utf-translate-cjk-mode on, and it also works to
turn it off.  That's good.

I'm sorry to cause you so much work; I wish I grokked the Mule code
better to fix it myself.
file-error; Data: (Opening input file no such file or directory ~/.signature)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]