[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: A plea for dynamically loadable extension modules

From: Nic
Subject: Re: A plea for dynamically loadable extension modules
Date: 30 Jul 2003 13:42:08 +0100

Mario Lang <address@hidden> writes:

> Is there any chance that we get the dynloading extention 
> for 21.4?  If not, could you please explain why? 

I think rms made a statement on this subject a number of months
ago. The reason dynamic loading has not been included in emacs so far
is that there would then be the potential of breaking the terms of
the licence under which emacs is distributed.

The GPL requires all code linked to emacs to also be Free. If
dynamic linking was allowed that couldn't be gauranteed.

The reason guile can do it is that guile is licenced under the
GPL+exception which allows for linking to non-commercial code.

Nic Ferrier

reply via email to

[Prev in Thread] Current Thread [Next in Thread]