[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

recent emacs crashiness/input-flakiness [X11 version related?]

From: Miles Bader
Subject: recent emacs crashiness/input-flakiness [X11 version related?]
Date: 28 Apr 2004 10:43:18 +0900

Recent versions of emacs have been very flaky for me, sometimes not
accepting keyboard input, sometimes crashing, etc.

I just compiled a new version without my personal patches, and it shows
the same behavior, so I think it must not be my patches at fault.
However, I'm beginning to think it has something to do with the X

  * If I start a tty emacs (-nw), it seems to work fine.

  * An X emacs, on the other hand, sometimes ignores keyboard input
    (though mouse input works fine), and sometimes crashes on the first
    keystroke, in _XimProcSyncReply[*].  Whether it crashes or ignores
    input seems to vary based on external factors like font and color,

      # Clear out my usual X resources:

         $ xrdb -remove

      # The following crashes upon the first keystroke:

         $ src/emacs -q

      # The following seems to work fine:

         $ src/emacs -q  \
              -fn -kappa-fixed-medium-r-normal--20-190-75-75-c-100-iso8859-1

      # The following crashes on the first keystroke:

        $ src/emacs -q  \
             -xrm '*Foreground: white' -xrm '*Background: black'

      # The following crashes on the first keystroke:

        $ src/emacs -q  \
             -fn -kappa-fixed-medium-r-normal--20-190-75-75-c-100-iso8859-1  \
             -xrm '*Foreground: white' -xrm '*Background: black'

  * This only happens at work, where I run debian unstable, not at
    home, where I run debian testing.

  * I thought at first maybe it was GTK-related (since I generally
    compile with the GTK toolkit, and I'm using a new GTK from debian
    experimental), but the above emacs was compiled without any X11
    toolkit support at all, and still shows the same behavior.  However,
    since the crashing seems X-related, and debian unstable has a fairly
    new version of X11 (4.3.0), I wonder if some interface has changed
    subtly or something.

Any ideas where I can look?  Crashes in the middle of X library routines
are hard for me to interpret.  Right now I'm fine using emacs in a
terminal window, but...



[*] Here's a GDB session (compressed; I used `backtrace full', so it's long):

Attachment: emacs-gdb-sess.gz
Description: Emacs GDB session, compressed

We live, as we dream -- alone....

reply via email to

[Prev in Thread] Current Thread [Next in Thread]