[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: M-x grep is too slow

From: Stefan Monnier
Subject: Re: M-x grep is too slow
Date: 13 Jul 2004 13:46:04 -0400
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3.50

> I tried the above but it finished quite soon.   But, when I tried:
>         M-x grep -nH -e while emacs/lisp/*/*.el
> it took long time.

I see it also.  Grep's output at first comes in fast and then at some point
it abruptly slows down and then it only comes in a couple chars at a time
(with enough time inbetween to see the steps).  Later on it switched again
to "fast" mode, and then switched again to "slow" mode, etc...

The problem is not the time taken in font-lock, but the fact that the text
gets inserted one char at a time (or maybe 2 or 3 chars, but it should not
happen that way; and as a matter of fact it does not happen that way when
grep's output comes in fast).

It seems related to the problem David had with AUCTeX on uniprocessors
running the Linux kernel with the "interactive" scheduler.  Kim installed
a patch to fix it, but maybe the patch isn't doing its job here for
some reason.

        Stefan "running on a uniprocessor Linux kernel"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]