[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs clipboard handling for X broken?

From: Werner LEMBERG
Subject: emacs clipboard handling for X broken?
Date: Tue, 31 Aug 2004 16:48:42 +0200 (CEST)

[Emacs CVS 2004-08-22]

I tried to paste text from Mozilla 1.6 (build 2004011400) into Emacs,
and I get e.g. for Chinese instead of `不想睡' the following:


I tried many coding systems in Emacs for the X selection (C-x RET x),
but all give the same result -- perhaps I've missed the right
one...  To be sure that it isn't a Mozilla problem or a problem of the
Window manager (I use fvwm 2.5.9), I pasted the text into the Unicode
editor yudit (version 2.7.6), and it worked.

Interestingly, pasting Chinese from Emacs to Mozilla (and to yudit)
works fine.

Another observation is that the mozilla's window border also show
\x{...} instead of Chinese characters...

Is this a known problem?  I'm lost and ask for help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]