[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Gnus version numbers (was: Gnus 5.10 is now on the trunk)

From: Reiner Steib
Subject: Gnus version numbers (was: Gnus 5.10 is now on the trunk)
Date: Thu, 09 Sep 2004 16:19:26 +0200
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.3.50 (gnu/linux)

On Thu, Sep 09 2004, Miles Bader wrote:

> BTW, aren't we supposed to change the version number to "5.11" now?

I also thought about this.

I propose to add another minor version number: Let us set it to 5.11.1
now.  After the release of Emacs 21.4, increase it again to 5.11.2 and
so on, so that each Emacs release also has a different Gnus version
(unless there are no changes in the Gnus code and manuals, maybe).

Rationale: In Emacs 21.1-21.3 all Gnus versions had 5.9 although the
Gnus version had significant differences.
E.g. `mm-coding-system-priorities' has been introduced in Emacs 21.2.
I don't remember how often I typed "if you have Gnus 5.9 that comes
with Emacs 21.2 or later you can set `mm-coding-system-priorities'

Additionally, each time a new Emacs version is released, we could
release an unbundled Gnus version from the Gnus v5-10 branch.
Assuming that Gnus in Emacs' CVS and the Gnus v5-10 branch in sync, of
course.  Lars, WDYT?

Bye, Reiner.
      (o o)
---ooO-(_)-Ooo---  |  PGP key available  |  http://rsteib.home.pages.de/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]