emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.0.44); emerge-files fails with remote ssh file


From: Michael Albinus
Subject: Re: tramp (2.0.44); emerge-files fails with remote ssh file
Date: Thu, 16 Sep 2004 12:25:54 +0200
User-agent: Gnus/5.1002 (Gnus v5.10.2) Emacs/20.7 (hpux)

Seki <address@hidden> writes:

>> I suspect it depends on the order you take the files: it will work if
>> the local file is the first one chosen, and the remote file is the
>> second one; and it will fail if you apply them the reverse order. (Or
>> vice-versa; don't blame me ...).
>
> That's it, I used for all my attempts to give my remote file at first
> and
> local file as second.
> Changing the order (that is: local as A and remote as B) fixed the
> 'No such file' problem, even if i cant figure at all why it makes a
> difference
> between these two alternatives ...

I haven't checked emerge-files, but it looks like it calls
`shell-command' being in buffer of the first file. `shell-command' is
handed to Tramp when `default-directory' of that buffer is a Tramp
file name. That makes the difference.

> But i have also tried to emerge 2 files that were both 8859-1-mac
> encoded and emerge
> failed with the same problem 'no newline at end'.
> So it seems that emerge can just merge unix encoded files ?

Looks like.

> Anyway it works now for me, and i have a recipe for my further merges :)
> Thank you very much Michael !

Maybe I did say it before already: I'm a happy ediff user for years;
no such problems ever. You could give it a try.

But anyway, the emerge-file problems should be fixed. I've cut
tramp-devel from the addressees of this thread.

> S├ębastien Kirche

Best regards, Michael.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]