[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[unicode-2 branch]emacs can't load library in "zh_CN.gbk" locale

From: zrr
Subject: [unicode-2 branch]emacs can't load library in "zh_CN.gbk" locale
Date: Mon, 04 Oct 2004 16:32:11 +0800
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.3.50 (gnu/linux)


  I have successfully compiled the most recent unicode-2 branch on
  my slackware box.(kernel, gcc 3.2.3, glibc-2.3.2)

  My default locale is "zh_CN.gbk". When I tried to run emacs with
  this command "./src/emacs -q", emacs starts up but complains
  "Cannot open load file: tool-bar". Actually, it can't load any

  Here is the full error message I have got:

    Loading mwheel...done
    (./emacs -q)
    Failure in loading charset map: "GBK" [5718 times]
    command-line: Cannot open load file: tool-barFailure in loading charset 
map: "GBK"
    Failure in loading charset map: "GBK" [50080 times]

  I managed to specify another locale for emacs in this way
  "LC_CTYPE=zh_CN.utf8 ./src/emacs -q". It works. After I tried some
  other locale settings, for instance, zh_CN.gb18030, en_US.utf8,
  etc. I realized that emacs only can't work in "zh_CN.gbk" locale.

  Is this a bug?

  By the way, it seems that a big change have been made on unicode
  emacs font selection method. I encountered some mess of font
  settings. Is there any new documentation about this topic?

Best Regards!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]