[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Current CVS doesn't bootstrap

From: Luc Teirlinck
Subject: Re: Current CVS doesn't bootstrap
Date: Sat, 6 Nov 2004 16:48:14 -0600 (CST)

Eli Zaretskii wrote:

   Btw, when I did a "cvs up" and tried to continue the failed bootstrap,
   it failed.  The commands I typed after "cvs up" were:

      make bootstrap.

   The last portion of the Make output is attached below.  I worked
   around the problem by doing a "make maintainer-clean" and then
   "make bootstrap".

   Any ideas, anyone?

I believe we discussed this before.  We either have to document in
INSTALL.CVS that you have to do `make maintainer-clean' before `make
bootstrap' or we have to make sure that `make bootstrap' removes the
.elc files automatically, as it used to do.  In the previous
discussion, I believe I understood that we decided on the latter and
that Kim planned to implement it, but I might have misunderstood.

Note that the problems with failing to do `make maintainer-clean' are
not just that bootstrapping may fail.  Sometimes one is able to
bootstrap without any problems, but the compiled files that Emacs is
using are not the same as the source files.  This is actually worse,
because one usually will not notice this and it can lead to plenty of
confusion when trying to debug stuff.  That is why I always run `make
maintainer-clean' before `make bootstrap'.  I ran into problems
continuously before I started doing so.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]