[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Current CVS doesn't bootstrap

From: Eli Zaretskii
Subject: Re: Current CVS doesn't bootstrap
Date: Sun, 07 Nov 2004 07:07:31 +0200

> Date: Sat, 6 Nov 2004 16:48:14 -0600 (CST)
> From: Luc Teirlinck <address@hidden>
> CC: address@hidden, address@hidden, address@hidden
> Eli Zaretskii wrote:
>    Btw, when I did a "cvs up" and tried to continue the failed bootstrap,
>    it failed.  The commands I typed after "cvs up" were:
>       ./configure
>       make bootstrap.
>    The last portion of the Make output is attached below.  I worked
>    around the problem by doing a "make maintainer-clean" and then
>    "make bootstrap".
>    Any ideas, anyone?
> I believe we discussed this before.

Can you point me to these discussions?  The only one I found by
searching the archives was inconclusive (because the problem
disappeared and the OP couldn't reproduce it anymore).

> We either have to document in INSTALL.CVS that you have to do `make
> maintainer-clean' before `make bootstrap' or we have to make sure
> that `make bootstrap' removes the .elc files automatically, as it
> used to do.

I don't think this is the right solution.  First, either
maintainer-clean or removing *.elc files causes the next bootstrap to
run much longer, so we should avoid that as much as we could.
Ideally, "make maintainer-clean" should be used only if "make
bootstrap" fails (and that is something that we should add to
INSTALL.CVS _right_now_).  We should look for a way to allow the
bootstrap to continue from the point the last one failed, without the
need to recompile all Lisp files.

In any case, I don't believe that stale *.elc files were the reason
for the failure in my case, because all "cvs up" did was to update a
single Lisp file: easymenu.el.  Why should that cause a failure with
loading cl-macs, and how removing *.elc files should fix that is
something I need to understand before I agree that the solutions you
mentioned are reasonable.  After all, the only file that failed to
compile was printing.el, so after updating easymenu.el, I'd expect the
bootstrap to proceed right from that point and thus time succeed,
right?  And yet it fails.  Why?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]