[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: DJGPP only dumps with USE_LISP_UNION_TYPE ??

From: Eli Zaretskii
Subject: Re: DJGPP only dumps with USE_LISP_UNION_TYPE ??
Date: Sun, 07 Nov 2004 23:56:32 +0200

> From: "Jan D." <address@hidden>
> Date: Sun, 7 Nov 2004 11:13:18 +0100
> I was trying to get Emacs to compile on djgpp 2.03.  But it crashed 
> every time in the dump phase, at the first GC.

Being the maintainer of the DJGPP port of Emacs, I build Emacs with
DJGPP every few days, and I never saw such a crash.  That includes the
current CVS which I just checked out.  This mail is being composed and
sent by an Emacs built from yesterday's CVS.

> I tried different gcc 
> versions (2.95, 3.22, 3.42), different binutils versions (2.11, 2.15), 

I'm using:

  gcc.exe (GCC) 3.3.3
  GNU ld version 2.14 20030612

(but none of the older versions ever crashed for me like that,
either).  My libc.a is a v2.03 with a few patches, but I doubt that
those patches could cause a GC crash.

> I tried set the USE_LISP_UNION_TYPE (found a couple of errors and
> checked them in)

Thanks.  I never tried USE_LISP_UNION_TYPE, and so I'm not surprised
it didn't work at first.

> Does this sound familiar to anyone?  Shouldn't with and without 
> USE_LISP_UNION_TYPE be the same at runtime?  I was wondering if this 
> could happen at other systems besides djgpp, and if there is some 
> subtle Lisp_Object handling bug somewhere.  I've attached some 
> debugging output.  If anyone has any idea and want more debugging done, 
> I can provide it.

I guess you need to provide as much info as possible.  Please begin by
posting a full transcript of the build, starting from "config msdos".
Then I'd like to see your system configuration (what OS and version

reply via email to

[Prev in Thread] Current Thread [Next in Thread]