[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: DJGPP only dumps with USE_LISP_UNION_TYPE ??

From: Eli Zaretskii
Subject: Re: DJGPP only dumps with USE_LISP_UNION_TYPE ??
Date: Thu, 11 Nov 2004 22:03:34 +0200

> Date: Tue, 09 Nov 2004 11:25:22 +0100
> From: "Jan D." <address@hidden>
> CC: address@hidden, address@hidden
> D:\src>gcc -v
> Reading specs from d:/djgpp/bin/../lib/gcc-lib/djgpp/3.34/specs
> Configured with: /gcc/gnu/gcc-3.34/configure djgpp --prefix=/dev/env/DJDIR 
> --dis
> able-nls
> Thread model: single
> gcc version 3.3.4
> D:\src>make align
> gcc     align.c   -o align
> D:\src>align
> ss1: rem 4
> ss2: rem 4
> ss3: rem 4
> ss4: rem 4

Up until now, I tried the test program on 2 XP boxes and one Windows
2000 machine, and the program printed zeros on all 3 of them (as it
did on Windows 98 and on plain DOS).  I wonder why you see different

How about if you send me the compiled binary (in private email,
please) as an attachment?

Also, I tried compiling the program with GCC 2.95.2 and got this

  align.c:14: warning: alignment of `ss1' is greater than maximum object file 
alignment. Using 4.

Didn't you see something like that when you tried to build Emacs with
GCC 2.9x?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]