[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

.mailcap on Windows / launching file attachments with "meadow" or "cygst

From: John Owens
Subject: .mailcap on Windows / launching file attachments with "meadow" or "cygstart" etc.
Date: Wed, 6 Apr 2005 19:14:56 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

Using GNU Emacs (i386-mingw-nt5.1.2600) of 2005-01-30

I run the "Wanderlust" mailer under emacs on both WinXP and OS X. In that 
mailer I would like to launch file attachments in mail messages (so that when 
I receive a PDF I can launch Acrobat to view it).

Wanderlust uses the MIME library called "SEMI", which has a method to "mime-
preview-play-current-entity". This looks in .mailcap to find out how to play 
the entity in question.

Now, on OS X, this all works fine. My mailcap has entries that look like the 

image/*: /sw/bin/launch -w %s

which uses the nice "launch" utility that simply launches the associated 
application with the file. All good. This works fine under CVS.

I have never got this to work under emacs on Windows. I was using the 21.3 
release for a while, recently updated to the CVS build from 30 January 
(above), and have tried a number of .mailcap entries to make this work. Among 
them are "cygstart" (from cygwin) and "fiber" (from meadow) that are both 
supposed to launch helper apps given a file name. When I call mime-preview-
play-current-entity, emacs records two messages:

Wrote c:/temp/EMI2060j4R/indep_study_proposal.doc
External method is starting...

and then nothing happens. No helper app launches. However, if I call, say,

weetabix 1% fiber -s c:/temp/EMI2060j4R/indep_study_proposal.doc

from the command line, everything works as I would expect.

If I try to quit emacs, I get a message like the following:

Proc                                                   Status   Buffer      
----                                                   ------   ------      ---
fiber -s "c:/temp/EMI2060j4R/indep_study_proposal.doc" run      *MIME-echo* 
C:/Program Files/emacs/bin/cmdproxy.exe -cf fiber -
s "c:/temp/EMI2060j4R/indep_study_proposal.doc"

I first thought this was a problem with my launcher, but now I'm leaning more 
toward emacs being the problem since I've tried a couple of launchers now. And 
since it works perfectly on OS X emacs, I don't think the fundamental approach 
is flawed.

Might I request some help in debugging this, or if others have .mailcap 
approaches that work fine, I'll happily hear those too?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]