[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tooltip-use-echo-area disappeared

From: Eli Zaretskii
Subject: Re: tooltip-use-echo-area disappeared
Date: Tue, 14 Jun 2005 23:35:05 +0200

> From: Nick Roberts <address@hidden>
> Date: Tue, 14 Jun 2005 16:30:04 +1200
> Cc: address@hidden, Jason Rumney <address@hidden>
> Resurrecting tooltip-use-echo-area is unrelated to making the tty version
> support tooltips.

IMO, it is related.

> It was just a flag that re-directed the output of tooltip-show-help
> to the echo area i.e. in the case of normal tooltips back to where
> it was displayed before tooltips were turned on.

If you mean to say that turning tooltips off would still display the
tooltip text in the echo area, then I agree with Jason: that's a bug
that should be fixed.  It should be possible to have 1 of 3 situations
wrt tooltips:

  (1) no tooltips and no messages in echo area
  (2) tooltip text is displayed in the echo area
  (3) tooltips are displayed as small floating windows

> Normal tooltips and GUD tooltips have quite different internals and 
> putting their associated code in separate files was much more modular.
> Previously if tooltip-use-echo-area was set to t so that normal tooltips
> displayed there, then GUD tooltips would display there.

Internals aside, from the user's point of view, if I want tooltip text
to be displayed in the echo area, I want ALL tooltips to behave like
that.  Why in the world would I like these two variants of tips to
behave differently?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]