[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[OSX] how to build for an older system ?

From: Sébastien Kirche
Subject: [OSX] how to build for an older system ?
Date: Mon, 25 Jul 2005 14:49:44 +0200
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (darwin)


I use to build Carbon Emacs on a G4/10.3.9 system (Fink installed).

Thanks to Steven Tamm I can build without the Fink shared libs with
make-package --self-contained -M,CC=gcc

And it executes without problem on more recent systems.

For  a  few  days, i  have  access  to  a  G3/10.4.2 system  (Fink  also

When i launch the binary compiled with 10.4.2 it fails under 10.3.9 with
the following :
    dyld:    /Applications/Emacs.app/Contents/MacOS/Emacs   can't   open
    library: /usr/lib/libncurses.5.4.dylib  (No such file  or directory,
    errno = 2) 

Obviously I have only libncurses.5.dylib and libncurses.dylib in 10.3.9

I tried a trivial
ln -s /usr/lib/libncurses.5.dylib /usr/lib/libncurses.5.4.dylib

But it then fails with the not surprising
    dyld:  /Applications/Emacs.app/Contents/MacOS/Emacs version mismatch
    for library: /usr/lib/libncurses.5.4.dylib (compatibility version of
    user: 5.4.0 greater than library's version: 5.0.0)

Is there a mean to build  Emacs.app in "compatibility mode" (read : give
a lower required  shared lib version) when the compilation  is made on a
recent system ?

Thanks for help.
Sébastien Kirche

reply via email to

[Prev in Thread] Current Thread [Next in Thread]