[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Better default values for tooltip padding and `tooltip-hide-delay'?

From: Richard M. Stallman
Subject: Re: Better default values for tooltip padding and `tooltip-hide-delay'?
Date: Thu, 13 Oct 2005 00:53:21 -0400

    What about changing the item names "Visit New File" into "Open New or
    Existing File" and "Open File" into "Open Existing File".

I think the existing names are good.
I do not want to consider changing them again.

    Hence one _definitely_ needs the help echo and it should even be more
    explicit.  What about changing it to:

    "Create a new file, or read an existing file, and edit it."

That is rather long, but I think

    "Create a file, and edit it"


    "Specify new file's name, to edit the file"

would make more sense than the current help-echo.

Just because this command CAN access an existing file is no reason we
must design the help-echo to mention that.  A complete description of
the command's range of possible behavior is not its purpose.  Its
purpose is to steer users in the right direction.

In general, completeness is a mistaken goal in writing documentation.
Covering all possible ways of invoking a function, or all possible
values a variable might have, is usually just wasteful--of our time,
and the user's time.  We only want to describe the cases that *should
be used*.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]