[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Release of CC Mode 5.31

From: Alan Mackenzie
Subject: Re: Release of CC Mode 5.31
Date: Tue, 6 Dec 2005 12:11:58 +0000 (GMT)

Hi, Eli!

On Sun, 4 Dec 2005, Eli Zaretskii wrote:

>> Date: Sat, 3 Dec 2005 11:48:02 +0000 (GMT)
>> From: Alan Mackenzie <address@hidden>
>> Cc: address@hidden, address@hidden, address@hidden
>> >For example, start Emacs with `emacs -q -nw', open src/alloc.c, you get
>> >the following messages:
>> >| Loading cc-mode...done
>> >| Eval error in the `c-lang-defvar' for `c-known-type-key': (void-function 
>> >mapcan)

>> I think I've fixed this, and I've commited the fix, in cc-langs.el, to
>> the repository.  It was a run-time `mapcan', which had to be replaced.
>> Could you test the fix, please?

>Sorry, but it doesn't seem to be fixed just yet.  I still get the same
>error message when I try to visit any *.c file (in "emacs -q"):

After downloading the new cc-langs.el, you need to byte-compile first
cc-langs.el (which builds the macro c-init-language-vars), then
cc-mode.el (which expands this macro (in the defun

>  Loading cc-mode...done
>  Eval error in the `c-lang-defvar' for `c-known-type-key': (void-function 
> mapcan)

Do you still get this problem, or has it gone away?

>I can see a few calls to mapcan in cc-langs.el, if that matters.

All of these (hopefully) are only called at byte-compile time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]