[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "wrong-type-argument listp" in cygwin

From: Eli Zaretskii
Subject: Re: "wrong-type-argument listp" in cygwin
Date: Fri, 24 Mar 2006 11:49:04 +0200

> Date: Fri, 24 Mar 2006 12:42:35 +0800
> From: "William Xue" <address@hidden>
> I got the emacs 22 sourcecode from the cvs and built in cygwin with make  
> this morning.
> After installed, when I opened the cpp file or .emacs, I got the error:
>       File mode specification error: (wrong-type-argument listp quote)
> Completed log is here:
> ---8<--------------------------------------------->8---
> (emacs)
> Loading encoded-kb...done
> Loading completion...done
> Loading edmacro...done
> Loading cl-macs...done
> Loading regexp-opt...done
> Loading term/rxvt...done
> For information about the GNU Project and its goals, type C-h C-p.
> Loading places from ~/.emacs-places...
> Loading places from /home/williamx/.emacs-places...done
> Error in pre-command-hook: (invalid-function ((quote  
> use-completion-minibuffer-separator)))
> Loading cc-mode...done
> File mode specification error: (wrong-type-argument listp quote)
> Unable to load color "PaleYellow"
> ---8<--------------------------------------------->8---
> BTW: Even I used 'emacs -nw' to start emacs in cygwin, I got the message:
>       $ emacs -nw
> Display :0 unavailable, simulating -nw

Thank you for your report.

I'm not sure if we have a developer who regularly builds the Cygwin
port.  So could you please debug these problems on your machine and
tell why Emacs fails?

Also, please tell the date when the sources were checked-out from CVS.

Thanks in advance.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]