emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: QNX subprocess bug


From: Kim F. Storm
Subject: Re: QNX subprocess bug
Date: Wed, 05 Apr 2006 11:01:14 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Stefan Monnier <address@hidden> writes:

> I think the best solution is to keep pid_t values (without changing them
> into Lisp_Object values) as long as possible, and to use floats when turning
> them into Lisp_Object.

Thanks Stefan.

This is a change that I have wanted to make for a very long time!

However, I would change the following not-really-Lisp_Object fields as well:

         unsigned pty_flag : 1;
           == !NILP (pty_flag)

         unsigned inherit_coding_system_flag : 1;
           == !NILP (inherit_coding_system_flag)

         unsigned read_output_skip : 1;
           == !NILP (read_output_skip)

         int read_output_delay;
           == XINT (read_output_delay)

The adaptive_read_buffering field could be replaced by two new
fields (which would also improve code readability):

       unsigned adaptive_read_buffering : 1;
          == !NILP (Vprocess_adaptive_read_buffering);
         
       unsigned adaptive_read_buffering_clear_on_write : 1;
          == EQ (Vprocess_adaptive_read_buffering, Qt)

I also noticed that the field encoding_carryover is no longer used,
so it can be deleted.

-- 
Kim F. Storm <address@hidden> http://www.cua.dk





reply via email to

[Prev in Thread] Current Thread [Next in Thread]