emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gpg-agent support removed?!


From: Daiki Ueno
Subject: Re: gpg-agent support removed?!
Date: Sat, 08 Apr 2006 19:11:30 +0900
User-agent: T-gnus/6.17.4 (based on No Gnus v0.4) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.6 XEmacs/21.4.16 (i686-pc-linux) MULE

>>>>> In <address@hidden> 
>>>>>   Romain Francoise <address@hidden> wrote:
> Richard Stallman <address@hidden> writes:

> > Romain, would you please explain to me why you removed the code in
> > Emacs CVS?

> To keep it level with the same code in Gnus, which we planned to include
> in a new Gnus stable release this week-end.

> > Why not install Daiki's fixes instead?

> Because they weren't available at the time,

As I said yesterday, the current version is at 
http://www.unixuser.org/~ueno/pgg-20060407.tar.gz
This code should be fairly stable.

> and because we had agreed to test this new code in the Gnus trunk.

I agreeded to revert the code from v5-10 branch of Gnus because the
release of Gnus v5.10.8 is so imminent.  However, I didn't think the
release of Emacs is as well.

> Anyway, Reiner has now changed it again in Gnus and Emacs to a later
> version that satisfies everyone, I think (revision 1.8 vs. 1.4).

No, I wasn't satisfied with your decision at all.  Though allout.el
appearantly has a bug, i.e. allout.el uses PGG in a bad way, it works as
expected by Ken (the author of allout.el), so it won't be fixed.  On the
other hand, I have many enhancement plans of PGG based on the new code
such as keysigning features, string-based interface, etc.  I think it
should be tested not only by the Gnus people but also by Emacs people.

Regards,
-- 
Daiki Ueno




reply via email to

[Prev in Thread] Current Thread [Next in Thread]