[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Incompatibility in emacs & aspell-0.60.4

From: Kevin Rodgers
Subject: Re: Incompatibility in emacs & aspell-0.60.4
Date: Tue, 29 Aug 2006 14:27:26 -0600
User-agent: Thunderbird (Windows/20060719)

djh wrote:
The error message is displayed after the 2nd successfull
(ispell-get-coding-system) upon trying to do another step.  See below:
File; ispell.el
Line: # 2535
        (set-process-coding-system ispell-process (ispell-get-coding-system)
                                   (ispell-get-coding-system) ))
Result: iso-8859-1 [2 times]
error: "Input file descriptor of ispell closed"
I have sent out a similar not to the aspell group, but I want to ask if anyone on this group has tried to use cvs emacs with aspell-0.60.4 and if so did you have the probelm I ran into?

I am using cvs emacs with aspell 0.60.4, on GNU/Linux, and I don't
encounter any error.  The description you gave is not enough to work
with.  Please give a self-contained recipe for reproducing the
problem, starting from `emacs -q'.

Same result with emacs -q.

GNU Emacs (i686-pc-cygwin, X toolkit) of 2006-08-29
CYGWIN_NT-5.1 1.5.21(0.156/4/2) 2006-07-30

Here is the self contained input to cause the error, iwthout fail, each time.

M-X ispell <CR>
RESULT displays:
"Starting new Ispell process [default] ..."
ispell-init-process: Error: nroff: dlopen returned "No such file or directory".

nroff does exist.  So why does yours work and mine doesn't?

This only happens when invoked from within emacs. Command line invocation seems 
to work fine.

Something between emacs and aspell is amiss.  But, I don't know where.  Help in 
finding it would be appreciated.

Was emacs invoked from the command line?  If you are invoking it via
a window manager, perhaps its environment was not initialized by your
shell's start up file, and that environment is being passed to aspell.

Why does ispell-init-process run nroff?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]