[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ftp freezes on w32

From: Lennart Borgman
Subject: Re: Ftp freezes on w32
Date: Tue, 07 Nov 2006 16:29:20 +0100
User-agent: Thunderbird (Windows/20060909)

Lennart Borgman wrote:
Lennart Borgman wrote:

I was wrong when I said I can work around the problem by deleting the inferior ftp process. I can't because I can not get rid of the ftp process. It seems impossible in Emacs on w32.

Does someone have any reciepe how to get ange-ftp to work on w32? I do not know of any way to get it working.

Forgot to say that kill-process does not kill the process immediately on w32. Is that a bug or by purpose?

Am I the only person here using ange-ftp (through tramp of course) on w32???

I have tried a couple of workarounds, but none has worked as I wish yet. What I thought would work was to kill and restart the ange ftp process in ange-ftp-send-cmd when ange-ftp-process-filter finds that the ftp process sends just nulls. I tried something like this then

   (delete-process proc)
  (while (not (eq 'exit (process-status proc)))
    (sit-for 1)
    (sleep-for 1) ;; Hope one of them works
   (message "process-status=%s" (process-status proc)))

This just loops and tells that the process is "signaled". Is there something else I can do here? (I have tried kill-process too with the same result.) I thought that sit-for or sleep-for would give Emacs a chance to finish the ftp process, but it does not seem so.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]